dwds 0.2.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new26

Dart Web Developer Service

Note: Under heavy development.

The Dart Web Developer Service (DWDS) allows developer tools designed to work with the native Dart VM to also work with Dart Web applications compiled with DDC, built/served with webdev, and run in Chrome.

DWDS will be integrated into the webdev.

At a basic level, DWDS proxies between:

0.2.1 #

  • Support setExceptionPauseMode.

0.2.0 #

  • Added custom tokens to the wsUri for increased security.
    • Treating this as a breaking change because you now must use the wsUri getter to get a valid uri for connecting to the service, when previously combining the port and host was sufficient.

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dwds: ^0.2.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dwds/service.dart';
  
Version Uploaded Documentation Archive
0.2.1 Apr 10, 2019 Go to the documentation of dwds 0.2.1 Download dwds 0.2.1 archive
0.2.0 Apr 9, 2019 Go to the documentation of dwds 0.2.0 Download dwds 0.2.0 archive
0.1.0 Mar 29, 2019 Go to the documentation of dwds 0.1.0 Download dwds 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
25
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
26
Learn more about scoring.

We analyzed this package on Apr 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.2.0.
 
 Because dwds requires SDK version >=2.2.1-dev.2.0 <3.0.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and dwds.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.1-dev.2.0 <3.0.0