edge_alert 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new76

Edge Alert #

A Flutter package that shows alert from top or bottom of the screen.

How to Use #

# add this line to your dependencies
edge_alert: ^0.0.1
import 'package:edge_alert/edge_alert.dart';
EdgeAlert.show(context, title: 'Title', description: 'Description', gravity: EdgeAlert.TOP);
propertydescription
contextBuildContext (Not Null)(required)
title'Your title goes here'
description'Your description goes here'
iconIconData (Default: Icons.notifications)
backgroundColorColor() (Default Colors.grey)
durationEdgeAlert.LENGTH_SHORT(1 second, Default) or EdgeAlert.LENGTH_LONG(2 sec) or EdgeAlert.LENGTH_VERY_LONG(3 sec)
gravityEdgeAlert.TOP(Default) or EdgeAlert.BOTTOM

EdgeAlert

Inspiration #

https://github.com/Tapadoo/Alerter/

License #

MIT License

0.0.1 #

  • Initial release.

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  edge_alert: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:edge_alert/edge_alert.dart';
  
Version Uploaded Documentation Archive
0.0.1 Apr 6, 2019 Go to the documentation of edge_alert 0.0.1 Download edge_alert 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
58
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
76
Learn more about scoring.

We analyzed this package on Apr 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/edge_alert.dart. (-3.45 points)

Analysis of lib/edge_alert.dart reported 7 hints, including:

line 6 col 20: Name non-constant identifiers using lowerCamelCase.

line 7 col 20: Name non-constant identifiers using lowerCamelCase.

line 8 col 20: Name non-constant identifiers using lowerCamelCase.

line 10 col 20: Name non-constant identifiers using lowerCamelCase.

line 11 col 20: Name non-constant identifiers using lowerCamelCase.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test