edit_distance 0.3.0

  • README.md
  • Example
  • Installing
  • Versions
  • 15

edit_distance #

Build Status

Implementation of string distance algorithms.

Description #

Edit distances algorithms for fuzzy matching. Specifically, this library provides:

Examples #

Levenshtein d = new Levenshtein();
print(d.distance('witch', 'kitsch')); // 2

Changelog #

0.3.0 #

  • Add Jaccard and CombinedJaccard.

0.2.1 #

  • Turn on strong mode
  • Fix a bug: JaroWinkler mistakenly used / operator where ~/ is required.

0.2.0 #

  • Add JaroWinkler and LongestCommonSubsequence.
  • Add NormalizedStringDistance whose normalizedDistance method returns a similarity between 0.0 (exact same) and 1.0 (completely different).

0.1.0 #

  • Initial version


// Copyright (c) 2016, Kwang Yul Seo. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:edit_distance/edit_distance.dart';

void main() {
  Levenshtein d = new Levenshtein();
  print(d.distance('witch', 'kitsch')); // 2
  print(d.normalizedDistance('witch', 'kitsch')); // 0.3333333333333333

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  edit_distance: ^0.3.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:edit_distance/edit_distance.dart';
Version Uploaded Documentation Archive
0.3.0 Nov 13, 2016 Go to the documentation of edit_distance 0.3.0 Download edit_distance 0.3.0 archive
0.2.1 Nov 3, 2016 Go to the documentation of edit_distance 0.2.1 Download edit_distance 0.2.1 archive
0.2.0 Oct 4, 2016 Go to the documentation of edit_distance 0.2.0 Download edit_distance 0.2.0 archive
0.1.0 Sep 28, 2016 Go to the documentation of edit_distance 0.1.0 Download edit_distance 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0