editor_build 0.0.5

  • README.md
  • Installing
  • Versions
  • 28

Dart Editor Build

This package allows a simple interaction with Dart Editor in build.dart. You can read Build.dart and the Dart Editor Build System to understand available interactions with Dart Editor.


When Dart Editor invokes build.dart

You can use the BuildOptions to parse arguments.

final opts = BuildOptions.parse(new Options().arguments);
opts.changed; // The list of files that changed and should be rebuilt.
opts.removed; // The list of files that was removed and might affect the build.
opts.clean; // bool
opts.full; // bool
opts.machine; // bool
opts.deploy; // bool

Provide results to Dart Editor

You can use BuildResult to create the output of build.dart.

final result = new BuildResult();
result.addError('foo.html', 23,'no ID found');
result.addWarning('foo.html', 24,'no ID found', charStart: 123, charEnd: 130);
result.addInfo('foo.html', 25,'no ID found');
result.addMapping('foo.html', 'out/foo.html');
print(result); // to provide information to editor


Apache 2.0

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  editor_build: "^0.0.5"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:editor_build/editor_build.dart';
Version Uploaded Documentation Archive
0.0.5 Oct 7, 2014 Go to the documentation of editor_build 0.0.5 Download editor_build 0.0.5 archive
0.0.4 Nov 9, 2013 Go to the documentation of editor_build 0.0.4 Download editor_build 0.0.4 archive
0.0.3 Oct 31, 2013 Go to the documentation of editor_build 0.0.3 Download editor_build 0.0.3 archive
0.0.2 Oct 12, 2013 Go to the documentation of editor_build 0.0.2 Download editor_build 0.0.2 archive
0.0.1 Jul 13, 2013 Go to the documentation of editor_build 0.0.1 Download editor_build 0.0.1 archive


We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
94 / 100
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:editor_build/editor_build.dart.


  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Package is too old.

    The package was released more than two years ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use editor_build.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 3 hints.

    Run dartfmt to format lib/editor_build.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=0.8.10+6 <2.0.0
args >=0.9.0 <0.13.0 0.12.2+6 1.4.3
Dev dependencies
unittest >=0.11.0 <0.12.0