editor_build 0.0.5

  • README.md
  • Installing
  • Versions
  • 0

Dart Editor Build

This package allows a simple interaction with Dart Editor in build.dart. You can read Build.dart and the Dart Editor Build System to understand available interactions with Dart Editor.

Usage

When Dart Editor invokes build.dart

You can use the BuildOptions to parse arguments.

final opts = BuildOptions.parse(new Options().arguments);
opts.changed; // The list of files that changed and should be rebuilt.
opts.removed; // The list of files that was removed and might affect the build.
opts.clean; // bool
opts.full; // bool
opts.machine; // bool
opts.deploy; // bool

Provide results to Dart Editor

You can use BuildResult to create the output of build.dart.

final result = new BuildResult();
result.addError('foo.html', 23,'no ID found');
result.addWarning('foo.html', 24,'no ID found', charStart: 123, charEnd: 130);
result.addInfo('foo.html', 25,'no ID found');
result.addMapping('foo.html', 'out/foo.html');
print(result); // to provide information to editor

License

Apache 2.0

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  editor_build: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:editor_build/editor_build.dart';
  
Version Uploaded Documentation Archive
0.0.5 Oct 7, 2014 Go to the documentation of editor_build 0.0.5 Download editor_build 0.0.5 archive
0.0.4 Nov 9, 2013 Go to the documentation of editor_build 0.0.4 Download editor_build 0.0.4 archive
0.0.3 Oct 31, 2013 Go to the documentation of editor_build 0.0.3 Download editor_build 0.0.3 archive
0.0.2 Oct 12, 2013 Go to the documentation of editor_build 0.0.2 Download editor_build 0.0.2 archive
0.0.1 Jul 13, 2013 Go to the documentation of editor_build 0.0.1 Download editor_build 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=0.8.10+6 <2.0.0