ee 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 4

event emitter for Dart

Build Status License Dart

A Dart event emitter implementation without any dependencies.

Requirement

  • dart>=1.20.0

Usage

import 'package:ee/ee.dart' show EventEmitter;

void main() {
  EventEmitter event = new EventEmitter();
  event.on('say hi', (name) {
    print('Hi! $name');   // Hi! Axetroy
  });
  event.emit('say hi', 'Axetroy');
}

Test

./scripts/test

Contribute

git clone https://github.com/axetroy/event-emitter.dart.git
cd ./event-emitter.dart
pub get
./scripts/test

You can flow Contribute Guide

License

The MIT License

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ee: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ee/ee.dart';
  
Version Uploaded Documentation Archive
0.0.3 Mar 4, 2017 Go to the documentation of ee 0.0.3 Download ee 0.0.3 archive
0.0.2 Mar 4, 2017 Go to the documentation of ee 0.0.2 Download ee 0.0.2 archive
0.0.1 Mar 4, 2017 Go to the documentation of ee 0.0.1 Download ee 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
4
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Health issues and suggestions

Fix lib/ee.dart. (-25 points)

Analysis of lib/ee.dart failed with 1 error:

line 55 col 28: The argument type '((dynamic) → void) → Null' can't be assigned to the parameter type '(dynamic) → void'.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Fix analysis_options.yaml.

We were unable to parse analysis_options.yaml.

Package is getting outdated. (-75.62 points)

The package was released 91 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use ee.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Dev dependencies
test any