ee 0.0.3

  • Installing
  • Versions
  • 57

event emitter for Dart

Build Status License Dart

A Dart event emitter implementation without any dependencies.


  • dart>=1.20.0


import 'package:ee/ee.dart' show EventEmitter;

void main() {
  EventEmitter event = new EventEmitter();
  event.on('say hi', (name) {
    print('Hi! $name');   // Hi! Axetroy
  event.emit('say hi', 'Axetroy');




git clone
cd ./event-emitter.dart
pub get

You can flow Contribute Guide


The MIT License



  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  ee: "^0.0.3"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:ee/ee.dart';
Version Uploaded Documentation Archive
0.0.3 Mar 4, 2017 Go to the documentation of ee 0.0.3 Download ee 0.0.3 archive
0.0.2 Mar 4, 2017 Go to the documentation of ee 0.0.2 Download ee 0.0.2 archive
0.0.1 Mar 4, 2017 Go to the documentation of ee 0.0.1 Download ee 0.0.1 archive


We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
43 / 100
Code health derived from static analysis. [more]
69 / 100
Reflects how tidy and up-to-date the package is. [more]
72 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:ee/ee.dart.


  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 1 hint.

    Strong-mode analysis of lib/ee.dart failed with the following error:

    line: 55 col: 28
    The argument type '((dynamic) → void) → Null' can't be assigned to the parameter type '(dynamic) → void'.

  • Fix analysis_options.yaml.

    We were unable to parse analysis_options.yaml.

  • Package is getting outdated.

    The package was released 66 weeks ago.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use ee.dart.

  • Enable strong mode analysis.

    Strong mode helps you to detect bugs and potential issues earlier.Start your analysis_options.yaml file with the following:

      strong-mode: true


Package Constraint Resolved Available
Dev dependencies