electron 0.0.3+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 27

electron.dart

electron.dart is a wrapper of the electron API in dart

Warning

This is under development so if you have suggestion on the existing API or you find a bug don't hesitate to fill an issue :)

Examples

You can find examples on how to use this package in the electron_examples repos

Changelog

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  electron: ^0.0.3+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:electron/electron_main.dart';
  
Version Uploaded Documentation Archive
0.0.3+1 Jul 21, 2016 Go to the documentation of electron 0.0.3+1 Download electron 0.0.3+1 archive
0.0.3 Jul 21, 2016 Go to the documentation of electron 0.0.3 Download electron 0.0.3 archive
0.0.2 Apr 30, 2015 Go to the documentation of electron 0.0.2 Download electron 0.0.2 archive
0.0.1 Apr 30, 2015 Go to the documentation of electron 0.0.1 Download electron 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
54
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
27
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0