elogger 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new55

easy for use #

only two steps

  1. import 'logger.dart';
  2. log('hello dart') or log(1+1)

and you will get some info from your console

result

you can click link to jump the line that you invoke log api

0.1 #

  • add divider
  • support code location

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  elogger: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.1.0 Apr 8, 2019 Go to the documentation of elogger 0.1.0 Download elogger 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
78
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on Apr 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Update README.md. (-2 points)

1 image link is insecure (e.g. http://ppmhqxt9k.bkt.clouddn.com/logger.png), use https URLs instead.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <3.0.0