emoji_feedback 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 72

emoji_feedback #

An mood feedback component which could be used for rating the user's mood.

Inspiration from Dribble

How to use #

import 'package:emoji_feedback/emoji_feedback.dart';
EmojiFeedback(onChange(index) { print(index);});
```



[0.0.1] - Released: basic version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  emoji_feedback: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:emoji_feedback/emoji_feedback.dart';
  
Version Uploaded Documentation Archive
0.1.0 Jan 13, 2019 Go to the documentation of emoji_feedback 0.1.0 Download emoji_feedback 0.1.0 archive
0.0.1 Jan 12, 2019 Go to the documentation of emoji_feedback 0.0.1 Download emoji_feedback 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
52
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
72
Learn more about scoring.

We analyzed this package on Feb 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13+1
  • Flutter: 1.2.1

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and emoji_feedback.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test