entity 0.9.3+4

  • README.md
  • Installing
  • Versions
  • 72

Entity

A very simple ORM for relational, NoSQL database, and simple maps. It is designed to work on browsers, so it doesn't use mirrors or annotations.

Build Status

Who Uses

  • Quire - a simple, collaborative, multi-level task management tool.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  entity: "^0.9.3+4"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:entity/entity.dart';
  
Version Uploaded Documentation Archive
0.9.3+4 Mar 26, 2018 Go to the documentation of entity 0.9.3+4 Download entity 0.9.3+4 archive
0.9.3+3 Jan 11, 2018 Go to the documentation of entity 0.9.3+3 Download entity 0.9.3+3 archive
0.9.3+2 Mar 17, 2017 Go to the documentation of entity 0.9.3+2 Download entity 0.9.3+2 archive
0.9.3 Mar 13, 2017 Go to the documentation of entity 0.9.3 Download entity 0.9.3 archive
0.9.2 Mar 13, 2017 Go to the documentation of entity 0.9.2 Download entity 0.9.2 archive
0.9.1 Oct 27, 2016 Go to the documentation of entity 0.9.1 Download entity 0.9.1 archive
0.9.0 Oct 13, 2016 Go to the documentation of entity 0.9.0 Download entity 0.9.0 archive
0.8.7+1 Jul 21, 2016 Go to the documentation of entity 0.8.7+1 Download entity 0.8.7+1 archive
0.8.7 Jul 9, 2016 Go to the documentation of entity 0.8.7 Download entity 0.8.7 archive
0.8.6 Dec 18, 2015 Go to the documentation of entity 0.8.6 Download entity 0.8.6 archive

All 35 versions...

Analysis

We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
72 / 100
Health:
Code health derived from static analysis. [more]
86 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
52 / 100
Overall score:
Weighted score of the above. [more]
72
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Error(s) in lib/postgresql.dart: Target of URI doesn't exist: 'package:postgresql/postgresql.dart'.

Suggestions

  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Error(s) in lib/postgresql.dart: Target of URI doesn't exist: 'package:postgresql/postgresql.dart'.

  • Running dartdoc failed.

    Make sure dartdoc runs without any issues.

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 10 errors 19 hints.

    Make sure that the imported libraries are not in conflict. Error(s) in lib/couchbase.dart: Target of URI doesn't exist: 'package:memcached_client/memcached_client.dart'.

    Make sure that the imported libraries are not in conflict. Error(s) in lib/postgresql.dart: Target of URI doesn't exist: 'package:postgresql/postgresql.dart'.

    Similar analysis of the following files failed:

    • lib/postgresql2.dart (error)
    • lib/src/postgresql/postgresql.dart (error)
    • lib/entity.dart (hint)
    • lib/map_storage.dart (hint)
    • lib/oid.dart (hint)
    • lib/src/entity/entity_access.dart (hint)
    • lib/src/entity/entity_core.dart (hint)
  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use entity.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.4.0
Dev dependencies
browser any
couchclient any
postgresql any
postgresql2 any
rikulo_commons >=2.0.0
test any