Enum Classes are now available from built_value.
Add this to your package's pubspec.yaml file:
dependencies: enum_class_generator: ^2.0.0
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
|2.0.0||Nov 22, 2016|
|1.1.2||Nov 14, 2016|
|1.1.1||Oct 19, 2016|
|1.1.0||Sep 21, 2016|
|1.0.0||Jul 11, 2016|
|0.2.2||Jun 7, 2016|
|0.2.1||Jun 6, 2016|
|0.2.0||May 30, 2016|
|0.1.0||May 25, 2016|
|0.0.6||Oct 23, 2015|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Add SDK constraint in
pubspec.yaml. (-50 points)
For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.
Package is too old. (-100 points)
The package was released more than two years ago.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use