epub_write 0.1.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

dart_epub_write

A library for Dart developers.

Usage

A simple usage example:

void main() async {
  var book = await EpubReader.readBook(new File("fic.epub").readAsBytesSync());
  var res = EpubWriter.writeBook(book);
  new File("res.epub").writeAsBytesSync(res, flush: true);
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

1.0.0

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  epub_write: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:epub_write/epub_write.dart';
  
Version Uploaded Documentation Archive
0.1.2 Jul 27, 2018 Go to the documentation of epub_write 0.1.2 Download epub_write 0.1.2 archive
0.1.1 Jul 26, 2018 Go to the documentation of epub_write 0.1.1 Download epub_write 0.1.1 archive
0.1.0 Jul 26, 2018 Go to the documentation of epub_write 0.1.0 Download epub_write 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.55.0 <2.0.0