eqdb_client 0.0.13

  • README.md
  • Installing
  • Versions
  • 0

EqDB HTTP API client

This library provides auto-generated client code for the EqDB JSON-over-HTTP API.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  eqdb_client: ^0.0.13

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:eqdb_client/eqdb_client.dart';
  
Version Uploaded Documentation Archive
0.0.13 Apr 30, 2017 Go to the documentation of eqdb_client 0.0.13 Download eqdb_client 0.0.13 archive
0.0.12 Apr 29, 2017 Go to the documentation of eqdb_client 0.0.12 Download eqdb_client 0.0.12 archive
0.0.11 Apr 21, 2017 Go to the documentation of eqdb_client 0.0.11 Download eqdb_client 0.0.11 archive
0.0.10 Apr 15, 2017 Go to the documentation of eqdb_client 0.0.10 Download eqdb_client 0.0.10 archive
0.0.9 Apr 14, 2017 Go to the documentation of eqdb_client 0.0.9 Download eqdb_client 0.0.9 archive
0.0.8 Apr 10, 2017 Go to the documentation of eqdb_client 0.0.8 Download eqdb_client 0.0.8 archive
0.0.7 Apr 10, 2017 Go to the documentation of eqdb_client 0.0.7 Download eqdb_client 0.0.7 archive
0.0.6 Apr 3, 2017 Go to the documentation of eqdb_client 0.0.6 Download eqdb_client 0.0.6 archive
0.0.5 Mar 29, 2017 Go to the documentation of eqdb_client 0.0.5 Download eqdb_client 0.0.5 archive
0.0.4 Mar 27, 2017 Go to the documentation of eqdb_client 0.0.4 Download eqdb_client 0.0.4 archive

All 13 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0