A Flutter plugin which provides access to all essential device features.
To use this plugin, add
essentials as a dependency in your pubspec.yaml file. For example:
dependencies: essentials: '^1.0.0'
NOTE: There's a known issue with integrating plugins that use Swift into a Flutter project created with the Objective-C template. See issue Flutter#16049 for help on integration.
Please file any issues, bugs or feature request as an issue on our GitHub page.
If you would like to contribute to the plugin (e.g. by improving the documentation, solving a bug or adding a cool new feature), please carefully review our contribution guide and send us your pull request.
Add this to your package's pubspec.yaml file:
dependencies: essentials: ^0.0.1
You can install packages from the command line:
$ flutter packages get
Alternatively, your editor might support
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.1||Sep 19, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
Document public APIs (-10 points)
6 out of 6 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.
lib/essentials.dart. (-0.50 points)
lib/essentials.dart reported 1 hint:
line 3 col 8: Unused import: 'dart:async'.
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use
Package is pre-v0.1 release. (-10 points)
While there is nothing inherently wrong with versions of
0.0.*, it usually means that the author is still experimenting with the general direction of the API.
|Dart SDK||>=2.0.0-dev.68.0 <3.0.0|