essentials 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 43

Flutter Essentials Plugin

pub package

A Flutter plugin which provides access to all essential device features.

BranchBuild Status
developBuild Status
masterBuild Status

Features

  • Geolocation
  • Permissions
  • Contacts

Usage

To use this plugin, add essentials as a dependency in your pubspec.yaml file. For example:

dependencies:
  essentials: '^1.0.0'

NOTE: There's a known issue with integrating plugins that use Swift into a Flutter project created with the Objective-C template. See issue Flutter#16049 for help on integration.

API

TODO

Issues

Please file any issues, bugs or feature request as an issue on our GitHub page.

Want to contribute

If you would like to contribute to the plugin (e.g. by improving the documentation, solving a bug or adding a cool new feature), please carefully review our contribution guide and send us your pull request.

Author

This essentials plugin for Flutter is developed by Baseflow. You can contact us at hello@baseflow.com

[1.0.0]

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  essentials: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:essentials/essentials.dart';
  
Version Uploaded Documentation Archive
0.0.1 Sep 19, 2018 Go to the documentation of essentials 0.0.1 Download essentials 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs (-10 points)

6 out of 6 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Fix lib/essentials.dart. (-0.50 points)

Analysis of lib/essentials.dart reported 1 hint:

line 3 col 8: Unused import: 'dart:async'.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use essentials.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
contacts_plugin ^0.0.1 0.0.3
flutter 0.0.0
geolocator >=1.6.4 <2.0.0 1.7.0 2.1.1
google_api_availability ^1.0.2 1.0.4
permission_handler >=2.0.0 <3.0.0 2.1.2
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test