estree_facade 1.0.0

  • README.md
  • Installing
  • Versions
  • 9

estree_facade

Dart ESTree FACADE.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  estree_facade: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:estree_facade/estree_facade.dart';
  
Version Uploaded Documentation Archive
1.0.0 Dec 17, 2016 Go to the documentation of estree_facade 1.0.0 Download estree_facade 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
31
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
9
Learn more about scoring.

We analyzed this package on Dec 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms:

Error(s) prevent platform classification:

Error(s) in lib/estree_facade.dart: 'FunctionDeclaration.body=' ('(BlockStatement) → void') isn't a valid override of 'BaseFunction.body=' ('(dynamic) → void').

Health issues and suggestions

Fix lib/estree_facade.dart. (-43.75 points)

Analysis of lib/estree_facade.dart failed with 2 errors:

line 527 col 3: 'FunctionDeclaration.body=' ('(BlockStatement) → void') isn't a valid override of 'BaseFunction.body=' ('(dynamic) → void').

line 706 col 3: 'FunctionExpression.body=' ('(BlockStatement) → void') isn't a valid override of 'BaseFunction.body=' ('(dynamic) → void').

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/estree_facade.dart: 'FunctionDeclaration.body=' ('(BlockStatement) → void') isn't a valid override of 'BaseFunction.body=' ('(dynamic) → void').

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use estree_facade.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0
js ^0.6.1 0.6.1+1