Dart ESTree FACADE.
Add this to your package's pubspec.yaml file:
dependencies: estree_facade: ^1.0.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.0||Dec 17, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Oct 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: web, other
lib/estree_facade.dart. (-43.75 points)
lib/estree_facade.dart failed with 2 errors:
line 527 col 3: Invalid override. The type of 'FunctionDeclaration.body=' ('(BlockStatement) → void') isn't a subtype of 'BaseFunction.body=' ('(dynamic) → void').
line 706 col 3: Invalid override. The type of 'FunctionExpression.body=' ('(BlockStatement) → void') isn't a subtype of 'BaseFunction.body=' ('(dynamic) → void').
dartdoc failed. (-10 points)
dartdoc runs without any issues.
CHANGELOG.md. (-20 points)
Changelog entries help clients to follow the progress in your code.
Package is getting outdated. (-83.29 points)
The package was released 95 weeks ago.
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use