estree_facade 1.0.0

  • Installing
  • Versions
  • 31



1. Depend on it

Add this to your package's pubspec.yaml file:

  estree_facade: "^1.0.0"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:estree_facade/estree_facade.dart';
Version Uploaded Documentation Archive
1.0.0 Dec 17, 2016 Go to the documentation of estree_facade 1.0.0 Download estree_facade 1.0.0 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
60 / 100
Reflects how tidy and up-to-date the package is. [more]
66 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: web, other

Primary library: package:estree_facade/estree_facade.dart with components: js.


  • Fix lib/estree_facade.dart.

    Strong-mode analysis of lib/estree_facade.dart failed with the following error:

    line: 527 col: 3
    Invalid override. The type of 'FunctionDeclaration.body=' ('(BlockStatement) → void') isn't a subtype of 'BaseFunction.body=' ('(dynamic) → void').

  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 1 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use estree_facade.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0
js ^0.6.1 0.6.1