eva_icons_flutter 1.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new75

eva_icons_flutter

Flutter package for Eva Icons. Eva Icons is a pack of more than 480 beautifully crafted Open Source icons for common actions and items.

This package brings Eva Icons pack available as Flutter Icons. It has beautiful outlined and rounded Icons.

Installation

In the dependencies: section of your pubspec.yaml, add the following line:

eva_icons_flutter: <latest_version>

Usage

import 'package:eva_icons_flutter/eva_icons_flutter.dart';

class MyWidget extends StatelessWidget {
  Widget build(BuildContext context) {
    return IconButton(
      // Use the EvaIcons class for the IconData
      icon: Icon(EvaIcons.heart),
      onPressed: () { print("Eva Icon heart Pressed"); }
     );
  }
}

Example

View the Flutter app in the example directory.

Screenshot

Eva Icons Screenshot

Contributors

1.0.4

  • More example added

1.0.3

  • Screenshot added

1.0.2

  • Example Updated

1.0.1

  • Example added

1.0.0

  • Usage details are added in README
  • Updated with Latest Eva Icons 1.0.2

0.0.2

  • All 480 Eva Icons Added

0.0.1

  • Package created with few icons

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:eva_icons_flutter/eva_icons_flutter.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      debugShowCheckedModeBanner: false,
      title: 'Eva Icons Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(),
    );
  }
}

class MyHomePage extends StatefulWidget {
  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        leading: IconButton(icon: Icon(EvaIcons.menu), onPressed: () {}),
        title: Text('Eva Icon Demo'),
        actions: <Widget>[
          IconButton(icon: Icon(EvaIcons.moreVertical), onPressed: () {})
        ],
      ),
      body: Center(
        child: Column(
          mainAxisAlignment: MainAxisAlignment.center,
          children: <Widget>[
            Row(
              children: <Widget>[
                Icon(EvaIcons.arrowBack),
                SizedBox(width: 10.0),
                Text('Arrow Back Icon')
              ],
            ),
            Row(
              children: <Widget>[
                Icon(EvaIcons.heart),
                SizedBox(width: 10.0),
                Text('Heart Icon')
              ],
            ),
            Row(
              children: <Widget>[
                Icon(EvaIcons.twitter),
                SizedBox(width: 10.0),
                Text('Twitter Icon')
              ],
            ),
            Row(
              children: <Widget>[
                Icon(EvaIcons.arrowCircleRight),
                SizedBox(width: 10.0),
                Text('Arrow Circle Right Icon')
              ],
            ),
            Row(
              children: <Widget>[
                Icon(EvaIcons.home),
                SizedBox(width: 10.0),
                Text('Home Icon')
              ],
            ),
            Row(
              children: <Widget>[
                Icon(EvaIcons.cloudUpload),
                SizedBox(width: 10.0),
                Text('Cloud Upload Icon')
              ],
            ),
            Row(
              children: <Widget>[
                Icon(EvaIcons.codeDownload),
                SizedBox(width: 10.0),
                Text('Code Download Icon')
              ],
            ),
            Row(
              children: <Widget>[
                Icon(EvaIcons.doneAllOutline),
                SizedBox(width: 10.0),
                Text('Done All Icon')
              ],
            ),
            Row(
              children: <Widget>[
                Icon(EvaIcons.emailOutline),
                SizedBox(width: 10.0),
                Text('Email Icon')
              ],
            ),
            Row(
              children: <Widget>[
                Icon(EvaIcons.swapOutline),
                SizedBox(width: 10.0),
                Text('Swap Icon')
              ],
            ),
            Row(
              children: <Widget>[
                Icon(EvaIcons.radioOutline),
                SizedBox(width: 10.0),
                Text('Radio Icon')
              ],
            ),
            Row(
              children: <Widget>[
                Icon(EvaIcons.options2Outline),
                SizedBox(width: 10.0),
                Text('Options Icon')
              ],
            ),
          ],
        ),
      ),
      floatingActionButton: FloatingActionButton(
        onPressed: () {},
        child: Icon(EvaIcons.plus),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  eva_icons_flutter: ^1.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:eva_icons_flutter/eva_icons_flutter.dart';
  
Version Uploaded Documentation Archive
1.0.4 Nov 4, 2018 Go to the documentation of eva_icons_flutter 1.0.4 Download eva_icons_flutter 1.0.4 archive
1.0.3 Nov 4, 2018 Go to the documentation of eva_icons_flutter 1.0.3 Download eva_icons_flutter 1.0.3 archive
1.0.2 Nov 4, 2018 Go to the documentation of eva_icons_flutter 1.0.2 Download eva_icons_flutter 1.0.2 archive
1.0.1 Nov 4, 2018 Go to the documentation of eva_icons_flutter 1.0.1 Download eva_icons_flutter 1.0.1 archive
1.0.0 Nov 4, 2018 Go to the documentation of eva_icons_flutter 1.0.0 Download eva_icons_flutter 1.0.0 archive
0.0.2 Nov 4, 2018 Go to the documentation of eva_icons_flutter 0.0.2 Download eva_icons_flutter 0.0.2 archive
0.0.1 Nov 4, 2018 Go to the documentation of eva_icons_flutter 0.0.1 Download eva_icons_flutter 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
75
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test