eventsource 0.2.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 72

eventsource #

A library for using EventSource or Server-Sent Events (SSE). Both client and server functionality is provided.

This library implements the interface as described here.

Client usage #

For more advanced usage, see the example/ directory. Creating a new EventSource client is as easy as a single call. The http package is used under the hood, so wherever this package works, this lbirary will also work. Browser usage is slightly different.

EventSource eventSource = await EventSource.connect("http://example.com/events");
// in browsers, you need to pass a http.BrowserClient:
EventSource eventSource = await EventSource.connect("http://example.com/events", 
    client: new http.BrowserClient());

Server usage #

We recommend using shelf_eventsource for serving Server-Sent Events. This library provides an EventSourcePublisher that manages subscriptions, channels, encoding. We refer to documentation in the shelf_eventsource package for more information.

This library also includes a server provider for dart:io's HttpServer in io_server.dart. However, it has some issues with data flushing that are yet to be resolved, so we recommend using shelf instead.

Licensing #

This project is available under the MIT license, as can be found in the LICENSE file.

Changelog #

0.1.0 (2016-11-27) #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  eventsource: ^0.2.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:eventsource/eventsource.dart';
  
Version Uploaded Documentation Archive
0.2.1 Nov 21, 2018 Go to the documentation of eventsource 0.2.1 Download eventsource 0.2.1 archive
0.2.0 Oct 9, 2018 Go to the documentation of eventsource 0.2.0 Download eventsource 0.2.0 archive
0.1.0+2 Apr 25, 2017 Go to the documentation of eventsource 0.1.0+2 Download eventsource 0.1.0+2 archive
0.1.0+1 Nov 28, 2016 Go to the documentation of eventsource 0.1.0+1 Download eventsource 0.1.0+1 archive
0.1.0 Nov 27, 2016 Go to the documentation of eventsource 0.1.0 Download eventsource 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
62
Health:
Code health derived from static analysis. [more]
71
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
97
Overall:
Weighted score of the above. [more]
72
Learn more about scoring.

We analyzed this package on Apr 25, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:eventsource/eventsource.dart.

Health issues and suggestions

Fix lib/publisher.dart. (-26.86 points)

Analysis of lib/publisher.dart failed with 1 error, 5 hints, including:

line 109 col 23: The argument type 'ProxySink' can't be assigned to the parameter type 'Sink<Event>'.

line 30 col 25: Use = to separate a named parameter from its default value.

line 31 col 25: Use = to separate a named parameter from its default value.

line 32 col 25: Use = to separate a named parameter from its default value.

line 53 col 51: Use = to separate a named parameter from its default value.

Fix lib/io_server.dart. (-1.49 points)

Analysis of lib/io_server.dart reported 3 hints:

line 15 col 20: Use = to separate a named parameter from its default value.

line 15 col 35: Use = to separate a named parameter from its default value.

line 21 col 47: 'ACCEPT_ENCODING' is deprecated and shouldn't be used.

Fix lib/src/encoder.dart. (-1.49 points)

Analysis of lib/src/encoder.dart reported 3 hints:

line 12 col 49: Use = to separate a named parameter from its default value.

line 25 col 15: 'GZIP' is deprecated and shouldn't be used.

line 49 col 19: 'GZIP' is deprecated and shouldn't be used.

Fix lib/src/event_cache.dart. (-0.50 points)

Analysis of lib/src/event_cache.dart reported 1 hint:

line 13 col 53: Use = to separate a named parameter from its default value.

Format lib/src/decoder.dart.

Run dartfmt to format lib/src/decoder.dart.

Maintenance suggestions

The package description is too short. (-3 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and eventsource.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <3.0.0
collection >=1.4.1 <2.0.0 1.14.11
http >=0.11.0 <0.13.0 0.12.0+2
http_parser >=2.2.0 <4.0.0 3.1.3
logging >=0.11.0 <0.12.0 0.11.3+2
sync >=0.1.0 <0.3.0 0.2.0
Transitive dependencies
async 2.2.0
charcode 1.1.2
meta 1.1.7
path 1.6.2
pedantic 1.5.0
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
test >=0.12.0 <2.0.0