evo 1.0.1+1

  • README.md
  • Changelog.md
  • Installing
  • Versions
  • 0

evo

A evolutionary algorithm library for Dart. Given a population of agents, an evaluator (fitness function), and time, the algorithm will evolve the population until it crosses given fitness threshold.

Evolution Strategies, sometimes also referred to as Evolutionary Strategies, and Evolutionary Programming are search paradigms inspired by the principles of biological evolution. They belong to the family of evolutionary algorithms that address optimization problems by implementing a repeated process of stochastic variations followed by selection: in each iteration (or generation), new candidate solutions (or offspring) are generated from previous candidate solutions (parents), their fitness is evaluated, and the better candidate solutions are selected to become the generators for the next iteration.

Read more about differential evolution on Wikipedia.

Changelog

1.0.1

  • Improve compatibility with coding conventions.
  • Bugfixes

1.0.0

  • Bugfixes.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  evo: ^1.0.1+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:evo/evo.dart';
  
Version Uploaded Documentation Archive
1.0.1+1 Dec 8, 2017 Go to the documentation of evo 1.0.1+1 Download evo 1.0.1+1 archive
1.0.1 Nov 25, 2017 Go to the documentation of evo 1.0.1 Download evo 1.0.1 archive
1.0.0 Nov 25, 2017 Go to the documentation of evo 1.0.0 Download evo 1.0.0 archive
0.0.3 Nov 25, 2017 Go to the documentation of evo 0.0.3 Download evo 0.0.3 archive
0.0.2 Nov 25, 2017 Go to the documentation of evo 0.0.2 Download evo 0.0.2 archive
0.0.1 Nov 25, 2017 Go to the documentation of evo 0.0.1 Download evo 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0