evo 1.0.1+1

  • README.md
  • Changelog.md
  • Installing
  • Versions
  • 47


A evolutionary algorithm library for Dart. Given a population of agents, an evaluator (fitness function), and time, the algorithm will evolve the population until it crosses given fitness threshold.

Evolution Strategies, sometimes also referred to as Evolutionary Strategies, and Evolutionary Programming are search paradigms inspired by the principles of biological evolution. They belong to the family of evolutionary algorithms that address optimization problems by implementing a repeated process of stochastic variations followed by selection: in each iteration (or generation), new candidate solutions (or offspring) are generated from previous candidate solutions (parents), their fitness is evaluated, and the better candidate solutions are selected to become the generators for the next iteration.

Read more about differential evolution on Wikipedia.



  • Improve compatibility with coding conventions.
  • Bugfixes


  • Bugfixes.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  evo: "^1.0.1+1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:evo/evo.dart';
Version Uploaded Documentation Archive
1.0.1+1 Dec 8, 2017 Go to the documentation of evo 1.0.1+1 Download evo 1.0.1+1 archive
1.0.1 Nov 25, 2017 Go to the documentation of evo 1.0.1 Download evo 1.0.1 archive
1.0.0 Nov 25, 2017 Go to the documentation of evo 1.0.0 Download evo 1.0.0 archive
0.0.3 Nov 25, 2017 Go to the documentation of evo 0.0.3 Download evo 0.0.3 archive
0.0.2 Nov 25, 2017 Go to the documentation of evo 0.0.2 Download evo 0.0.2 archive
0.0.1 Nov 25, 2017 Go to the documentation of evo 0.0.1 Download evo 0.0.1 archive


We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
96 / 100
Reflects how tidy and up-to-date the package is. [more]
90 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:evo/evo.dart.


  • Homepage does not exists.

    We were unable to access https://plus.google.com/+Welopment at the time of the analysis.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 12 hints.

    Strong-mode analysis of lib/src/agent.dart gave the following hint:

    line: 2 col: 8
    Unused import: './agent.dart'.

    Strong-mode analysis of lib/src/agentPool.dart gave the following hint:

    line: 6 col: 17
    The value of the local variable 'vector' isn't used.

    Similar analysis of the following files failed:

    • lib/src/algorithm.dart (hint)
    • lib/src/crossover.dart (hint)
  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use evo.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
Dev dependencies
test ^0.12.28