ex_map 0.10.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

c9 - editor

Build Status pub package

A library for writing pretty simple object class with Map interface.

Use transformer:

transformers:
  - ex_map

And that:

library ex_map_test;
import 'package:ex_map/ex_map.dart';

@ExMap
class TestMap extends ExtendedMap {
  @ExKey()
  int id;
  
  @ExKey(protected: true, type: int)
  String integerField; 
  
  @ExKey(type: String)
  var testField;
  
  var notAnnotatedProperty;
}

will be transformed to:

library ex_map_test;
import 'package:ex_map/ex_map.dart';

@ExMap
class TestMap extends ExtendedMap {
  TestMap({int id, int integerField, String testField}) {
    protectedKeys.addAll(['integerField']);
    types = {'id': int, 'integerField': int, 'testField': String};
  }
  
  get id => this['id'];
  set id(value) => this['id'] = value;
  
  get integerField => this['integerField'];
  set integerField(value) => setProtectedField('integerField', value);
  
  get testField => this['testField'];
  set testField(value) => this['testField'] = value;
  
  var notAnnotatedProperty;
}

protectedKeys - can not be set differently than through special method. (setProtectedField) That property can be established only through the operator: "."

types - need to check type of value before save:

class FieldsTestMap extends ExtendedMap {
  FieldsTestMap({id, integerField, testField}) {
    types = {
      'stringField': String,
      'intField': int,
      'doubleField': double,
      'dateField': DateTime,
      'boolField': bool
    };
  }
  
  /// Test
  group('The extended map', () {
    test('has right types', () {
      FieldsTestMap map = new FieldsTestMap();

      map['stringField'] = 1;
      expect(map.stringField, equals('1'));

      map['stringField'] = '2';
      expect(map.stringField, equals('2'));

      map['intField'] = '1';
      expect(map.intField, equals(1));

      map['intField'] = 2;
      expect(map.intField, equals(2));

      map['doubleField'] = '2.2';
      expect(map.doubleField, equals(2.2));

      map['doubleField'] = 2.1;
      expect(map.doubleField, equals(2.1));

      DateTime date = new DateTime.now();
      map['dateField'] = date.toString();
      expect(map.dateField, equals(date));

      map['dateField'] = date;
      expect(map.dateField, equals(date));

      map['boolField'] = 'true';
      expect(map.boolField, equals(true));

      map['boolField'] = false;
      expect(map.boolField, equals(false));
    });
  });
TODO:
  • Default constructor check in transformer

ExMap Change Log

0.10.2

  • Update readme
  • Update version

0.10.1

  • Update readme

example/example.dart

library example;

import 'dart:html';
import 'package:ex_map/ex_map.dart';

@ExMap
class ExampleMap extends ExtendedMap {
  @ExKey()
  int id;

  @ExKey(protected: true, type: int)
  int integerField = 1;

  @ExKey(type: String)
  var testField = 'test';
}

main() {
  ExampleMap exampleMap = new ExampleMap();
  exampleMap['id'] = 1;
  querySelector('body')
    ..appendText('keys: ${exampleMap.keys.toString()}')
    ..append(new Element.br())
    ..appendText('id: ${exampleMap.id}')
    ..append(new Element.br())
    ..appendText('integerField: ${exampleMap.integerField}')
    ..append(new Element.br())
    ..appendText('testField: ${exampleMap["testField"]}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ex_map: ^0.10.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ex_map/ex_map.dart';
  
Version Uploaded Documentation Archive
0.10.2 Aug 15, 2016 Go to the documentation of ex_map 0.10.2 Download ex_map 0.10.2 archive
0.10.1 Aug 15, 2016 Go to the documentation of ex_map 0.10.1 Download ex_map 0.10.1 archive
0.9.9 Aug 14, 2016 Go to the documentation of ex_map 0.9.9 Download ex_map 0.9.9 archive
0.9.8 Aug 15, 2016 Go to the documentation of ex_map 0.9.8 Download ex_map 0.9.8 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.14.0 <2.0.0