exifdart 0.6.0+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 24

exifdart

Dart module to decode Exif data from jpeg files.

Dart port based on Exif.js: https://github.com/exif-js/exif-js/

Installation

Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  exifdart:

Install it

You can install packages from the command line:

$ pub get

Usage

Simple example:

// Add this to have the Rational class too:
// import "package:package:exifdart/exifdart.dart";

// We are not using that in this example, this alone will do fine:
import "package:package:exifdart/exifdart_html.dart";
import "dart:html";

/// Returns the orientation value or `null` if no EXIF or no orientation info
/// is found.
Future<int> getOrientation(Blob blob) async {
  if (blob.type == "image/jpeg") {
    Map<String, dynamic> tags = await readExifFromBlob(blob);
    return tags["Orientation"];
  }

  return null;
}

void main() {
  registerChangeHandler(document.querySelector("input[type=file]"));
}

void registerChangeHandler(InputElement input) {
  input.onChange.listen((Event e) {
    for (File f in input.files) {
      getOrientation(f).then((int orientation) {
        window.console.log("Orientation for ${f.name} is ${orientation}");
      });
    }
  });
}

0.6.0+1

  • fixed the botched release

0.6.0

  • created AbstractBlobReader making the core implementation platform independent
  • moved platform dependent code (a HTML Blob based implementation of AbstractBlobReader) available by importing exifdart_html.dart
  • created a dart:io based implementation of AbstractBlobReader and made it available in exifdart_io.dart
  • this is an API breaking release, you have to import both exifdart.dart and exifdart_html.dart ot get the old API

0.5.0+6

  • fixed null access on some files that have a type 0 GPSVersionID tag

0.5.0+5

  • fixed offset errors in BlobView and CacheView

0.5.0+4

  • changed switch block to make dart2js happy

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  exifdart: ^0.6.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:exifdart/exifdart.dart';
  
Version Uploaded Documentation Archive
0.6.0+1 Jul 13, 2018 Go to the documentation of exifdart 0.6.0+1 Download exifdart 0.6.0+1 archive
0.6.0 Jul 12, 2018 Go to the documentation of exifdart 0.6.0 Download exifdart 0.6.0 archive
0.5.0+6 Mar 14, 2018 Go to the documentation of exifdart 0.5.0+6 Download exifdart 0.5.0+6 archive
0.5.0+5 Jan 5, 2018 Go to the documentation of exifdart 0.5.0+5 Download exifdart 0.5.0+5 archive
0.5.0+4 Dec 7, 2017 Go to the documentation of exifdart 0.5.0+4 Download exifdart 0.5.0+4 archive
0.5.0+3 Nov 23, 2017 Go to the documentation of exifdart 0.5.0+3 Download exifdart 0.5.0+3 archive
0.5.0+2 May 8, 2017 Go to the documentation of exifdart 0.5.0+2 Download exifdart 0.5.0+2 archive
0.5.0+1 May 8, 2017 Go to the documentation of exifdart 0.5.0+1 Download exifdart 0.5.0+1 archive
0.5.0 May 8, 2017 Go to the documentation of exifdart 0.5.0 Download exifdart 0.5.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
48
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
24
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.16.0-dev.5.0 <2.0.0