exwidgets 1.0.16+2

  • README.md
  • changelog.md
  • Installing
  • Versions
  • new37

monitor_nav

1.0.1

  • 3 New Screens Added

    • Profile 2
    • Login 2
    • Payment Success
  • Minor Bug Fixes

1.0.0

  • Initial(Early) Release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  exwidgets: ^1.0.16+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:exwidgets/core.dart';
import 'package:exwidgets/demo.dart';
import 'package:exwidgets/main.dart';
  
Version Uploaded Documentation Archive
1.0.16+2 Dec 6, 2018 Go to the documentation of exwidgets 1.0.16+2 Download exwidgets 1.0.16+2 archive
1.0.15+2 Dec 3, 2018 Go to the documentation of exwidgets 1.0.15+2 Download exwidgets 1.0.15+2 archive
1.0.14+2 Dec 3, 2018 Go to the documentation of exwidgets 1.0.14+2 Download exwidgets 1.0.14+2 archive
1.0.13+2 Nov 30, 2018 Go to the documentation of exwidgets 1.0.13+2 Download exwidgets 1.0.13+2 archive
1.0.12+2 Nov 30, 2018 Go to the documentation of exwidgets 1.0.12+2 Download exwidgets 1.0.12+2 archive
1.0.11+2 Nov 30, 2018 Go to the documentation of exwidgets 1.0.11+2 Download exwidgets 1.0.11+2 archive
1.0.10+2 Nov 30, 2018 Go to the documentation of exwidgets 1.0.10+2 Download exwidgets 1.0.10+2 archive
1.0.9+2 Nov 30, 2018 Go to the documentation of exwidgets 1.0.9+2 Download exwidgets 1.0.9+2 archive
1.0.8+2 Nov 30, 2018 Go to the documentation of exwidgets 1.0.8+2 Download exwidgets 1.0.8+2 archive
1.0.7+2 Nov 30, 2018 Go to the documentation of exwidgets 1.0.7+2 Download exwidgets 1.0.7+2 archive

All 16 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
51
Health:
Code health derived from static analysis. [more]
18
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
37
Learn more about scoring.

We analyzed this package on Dec 6, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms:

Low code quality prevents platform classification.

Health issues and suggestions

Fix lib/src/action_button/ex_action_button.dart. (-43.75 points)

Analysis of lib/src/action_button/ex_action_button.dart failed with 2 errors:

line 3 col 8: Target of URI doesn't exist: 'package:exwidgets/src/helper/instance_manager.dart'.

line 31 col 5: Undefined name 'InstanceManager'.

Fix lib/src/form_element/ex_date.dart. (-43.75 points)

Analysis of lib/src/form_element/ex_date.dart failed with 2 errors:

line 4 col 8: Target of URI doesn't exist: 'package:exwidgets/src/helper/instance_manager.dart'.

line 83 col 5: Undefined name 'InstanceManager'.

Fix lib/src/form_element/ex_image.dart. (-43.75 points)

Analysis of lib/src/form_element/ex_image.dart failed with 2 errors:

line 3 col 8: Target of URI doesn't exist: 'package:exwidgets/src/helper/instance_manager.dart'.

line 35 col 5: Undefined name 'InstanceManager'.

Fix lib/src/form_element/image_uploader/ex_image_uploader.dart. (-0.50 points)

Analysis of lib/src/form_element/image_uploader/ex_image_uploader.dart reported 1 hint:

line 5 col 8: Unused import: 'package:http/http.dart'.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Low code quality prevents platform classification.

Homepage does not exists. (-20 points)

We were unable to access https://anagatadev.com/extreme-widget/ at the time of the analysis.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use exwidgets.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.47.0 <3.0.0
cloud_firestore ^0.8.2+2 0.8.2+3
cupertino_icons ^0.1.2 0.1.2
firebase_auth ^0.6.6 0.6.6
firebase_core ^0.2.5+1 0.2.5+1
firebase_messaging ^2.1.0 2.1.0
firebase_storage ^1.0.4 1.0.4
flutter 0.0.0
flutter_local_notifications ^0.4.2 0.4.2+1
flutter_localizations 0.0.0
flutter_masked_text ^0.7.0 0.7.0
font_awesome_flutter ^8.2.0 8.2.0
geolocator ^2.1.0 2.1.1
google_maps_flutter ^0.0.1 0.0.3+3
google_sign_in ^3.2.4 3.2.4
http ^0.12.0 0.12.0
image_picker ^0.4.10 0.4.10
intl ^0.15.7 0.15.7
path_provider ^0.4.1 0.4.1
rxdart ^0.19.0 0.19.0
sqflite ^0.12.2+1 0.12.2+1 0.13.0
url_launcher ^4.0.1 4.0.2
uuid ^1.0.3 1.0.3
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
convert 2.0.2
crypto 2.0.6
google_api_availability 1.0.4
http_parser 3.1.3
meta 1.1.6
path 1.6.2
permission_handler 2.1.2
platform 2.2.0
sky_engine 0.0.99
source_span 1.4.1
string_scanner 1.0.4
synchronized 1.5.3
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
random_pk any