f_events 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

f_events

A library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.

Usage

A simple usage example:

import 'package:f_events/f_events.dart';
    
class Event {
  String data;

  Event(this.data);
}

void main() {
  event.register('event_name', new Event());
  event.listen('event_name', (Event event) => print(event.data));
        
  event.call('event_name', positionalArguments: ['String']);
}

Todo

  • [ ] Write examples
  • [ ] tests 100%
  • [ ] Make lazy loading
  • [ ] Make mechanism for automatically calling events from property in listener

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  f_events: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:f_events/f_events.dart';
  
Version Uploaded Documentation Archive
1.0.0 Mar 23, 2018 Go to the documentation of f_events 1.0.0 Download f_events 1.0.0 archive
0.2.0 Mar 23, 2018 Go to the documentation of f_events 0.2.0 Download f_events 0.2.0 archive
0.1.0 Mar 21, 2018 Go to the documentation of f_events 0.1.0 Download f_events 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0