facebook 0.0.4

  • README.md
  • Example
  • Installing
  • Versions
  • new46

This plugin allow you to easily connect user to facebook

How to use it

You can find an example here


import 'dart:async';
import 'package:facebook/facebook.dart';

Future<Null> main() async {

  await fbAsyncInit();
    new FbInitOption(
      appId: 'YOUR_APP_ID',
      cookies: true,
      xfbml: true,
      version: 'v2.9',
  var response = await getLoginStatus();
  if (response.status != LoginStatus.connected) {
    response = await login();

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  facebook: "^0.0.4"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:facebook/facebook.dart';
Version Uploaded Documentation Archive
0.0.4 Jun 15, 2018 Go to the documentation of facebook 0.0.4 Download facebook 0.0.4 archive
0.0.3 Jun 15, 2018 Go to the documentation of facebook 0.0.3 Download facebook 0.0.3 archive
0.0.2 Jun 6, 2018 Go to the documentation of facebook 0.0.2 Download facebook 0.0.2 archive


We analyzed this package on Jun 15, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
80 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: web, other

Primary library: package:facebook/facebook.dart with components: js.


  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
dart_browser_loader ^0.0.4 0.0.4
js ^0.6.1 0.6.1
Dev dependencies
browser ^0.10.0 0.10.0+3
dart_to_js_script_rewriter ^1.0.1