fake_tencent 0.1.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new50

fake_tencent #

Build Status GitHub tag pub package

flutter版腾讯(QQ)SDK

fake 系列 libraries #

  1. flutter版okhttp3
  2. flutter版微信SDK
  3. flutter版腾讯(QQ)SDK
  4. flutter版新浪微博SDK
  5. flutter版支付宝SDK

dart/flutter 私服 #

simple_pub_server

android #

...
android {
    ...
    defaultConfig{
        ...
        manifestPlaceholders = [TENCENT_APP_ID: "${appId}"]
        ...
    }
    ...
}
...
# 混淆已打入 Library,随 Library 引用,自动添加到 apk 打包混淆

ios #

在Xcode中,选择你的工程设置项,选中“TARGETS”一栏,在“info”标签栏的“URL type“添加“URL scheme”为你所注册的应用程序id

URL Types
tencent: identifier=tencent schemes=tencent${appId}
iOS 9系统策略更新,限制了http协议的访问,此外应用需要在“Info.plist”中将要使用的URL Schemes列为白名单,才可正常检查其他应用是否安装。

<key>LSApplicationQueriesSchemes</key>
<array>
    <string>wtloginmqq2</string>
    <string>mqqopensdkapiV3</string>
    <string>mqqwpa</string>
    <string>mqqopensdkapiV2</string>
    <string>mqqOpensdkSSoLogin</string>
    <string>mqq</string>
</array>
<key>NSAppTransportSecurity</key>
<dict>
    <key>NSAllowsArbitraryLoads</key>
    <true/>
</dict>

flutter #

分享类型说说图片音乐视频网页
QQ不支持支持支持不支持支持
QZone支持不支持不支持不支持支持

snapshot #

dependencies:
  fake_tencent:
    git:
      url: https://github.com/v7lin/fake_tencent.git

release #

latestVersion = 0.1.0
dependencies:
  fake_tencent: ^${latestVersion}

example #

示例

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.1 - 2019.3.1 #

  • android/ios tencent

0.1.0 - 2019.3.19 #

  • 规范 fake_tencent 代码

example/README.md

fake_tencent_example #

Demonstrates how to use the fake_tencent plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fake_tencent: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fake_tencent/fake_tencent.dart';
  
Version Uploaded Documentation Archive
0.1.0 Mar 20, 2019 Go to the documentation of fake_tencent 0.1.0 Download fake_tencent 0.1.0 archive
0.0.1+1 Mar 4, 2019 Go to the documentation of fake_tencent 0.0.1+1 Download fake_tencent 0.0.1+1 archive
0.0.1 Mar 1, 2019 Go to the documentation of fake_tencent 0.0.1 Download fake_tencent 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Mar 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/fake_tencent.dart.

Run flutter format to format lib/fake_tencent.dart.

Format lib/src/domain/tencent_resp.dart.

Run flutter format to format lib/src/domain/tencent_resp.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
jaguar_serializer ^2.2.12 2.2.12
meta ^1.1.6 1.1.6 1.1.7
Transitive dependencies
collection 1.14.11
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
build_runner ^1.2.3
flutter_test
jaguar_serializer_cli ^2.2.5
pedantic >=1.4.0 <3.0.0