fart_scroll 1.0.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new50

fart_scroll

You want fart noises as you scroll? I've got you covered.

Everyone farts. And now your apps* can too.

Heavily inspired by fartscroll.js

How to use

Simply mixin FartScrollMixin with your State and pass fartScrollController to a widget which takes a ScrollController.

class _HomePageState extends State<HomePage> with FartScrollMixin<HomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('Home'),
      ),
      body: ListView.builder(
          controller: fartScrollController,
          itemCount: 500,
          itemBuilder: (_, index) {
            return ListTile(title: Text("Item $index"));
          }),
    );
  }
}

[1.0.0] - 12/23/2018

  • Initial fart. 💨

example/README.md

example

Example app of fart_scroll package.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fart_scroll: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fart_scroll/fart_scroll.dart';
  
Version Uploaded Documentation Archive
1.0.0 Dec 23, 2018 Go to the documentation of fart_scroll 1.0.0 Download fart_scroll 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/fart_scroll.dart. (-0.50 points)

Analysis of lib/fart_scroll.dart reported 1 hint:

line 57 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
audioplayers ^0.7.8 0.7.8 0.8.0
flutter 0.0.0
Transitive dependencies
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
meta 1.1.6 1.1.7
path_provider 0.4.1
sky_engine 0.0.99
typed_data 1.1.6
uuid 1.0.3 2.0.0-rc1
vector_math 2.0.8
Dev dependencies
flutter_test