fbsdk 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 25

STILL IN DEVELOPMENT, FEEL FREE TO CONTRIBUTE.

Flutter FBSDK

Flutter FBSDK is a wrapper around the iOS Facebook SDK and Android Facebook SDK, allowing for Facebook integration in Flutter apps. Access to native components, from login to sharing, is provided entirely through documented JavaScript modules so you don't have to call a single native function directly.

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

Installation

Android Setup (The example app includes an example of the setup): in progress

iOS Setup (The example app includes an example of the setup): in progress

License

See the LICENSE file.

Platform Policy

Developers looking to integrate with the Facebook Platform should familiarize themselves with the Facebook Platform Policy.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:fbsdk/login_kit.dart';
import 'package:fbsdk/share_kit.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Plugin example app'),
        ),
        body: new Center(
          child: new Column(children: [
            new Container(
              child: new RaisedButton(
                  child: new Text("Login to Facebook"),
                  onPressed: () async {
                    final response = await FacebookLoginKit
                        .loginWithReadPermissions(["public_profile"]);
                    print(response);
                  }),
              margin: const EdgeInsets.only(top: 32.0),
            ),
            new Container(
              child: new RaisedButton(
                child: new Text("Share some content"),
                onPressed: () async {
                  final response =
                      await FacebookShareKit.shareLinkWithShareDialog({
                    "contentType": 'link',
                    "contentUrl": "https://facebook.com",
                    "contentDescription": 'Wow, check out this great site!'
                  });
                  print(response);
                },
              ),
              margin: const EdgeInsets.only(top: 32.0),
            )
          ]),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fbsdk: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fbsdk/login_kit.dart';
import 'package:fbsdk/share_kit.dart';
  
Version Uploaded Documentation Archive
0.0.2 Feb 23, 2018 Go to the documentation of fbsdk 0.0.2 Download fbsdk 0.0.2 archive
0.0.1 Feb 23, 2018 Go to the documentation of fbsdk 0.0.1 Download fbsdk 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
25
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0