feather 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 17

Feather

A flutter utility library with re-frame esk features and miscellaneous functions

[0.1.0] - Minor Release

Feather has proven stable enough for a minor release

Fixes:

  • Issue with setting the initial AppDb state.

[0.0.6] - Or->ifVal

Renamed or to ifVal

[0.0.5] - Null Checks

Adds isNull and isNotNull

[0.0.4] - Conditional Functions

Adds support for when and or functions with lazyish evaluation

[0.0.3] - Casting Functions

Adds typecasting functionality for List<dynamic> to:

  • Map with asMaps
  • Widget with asWidgets
  • nonNullMaps
  • nonNullWidgets

Fixed some Dart 2 assertion checks.

[0.0.2] - Merge Function

Adds functionality for:

  • Utilities
    • merge

[0.0.1] - Initial Release

Provides functionality for:

  • Flow
    • AppDb
    • AppDbStream Stream View
  • Utilities
    • get/getIn
    • set/setIn
    • remove/removeIn
    • removeNulls
    • contains

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  feather: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:feather/feather.dart';
  
Version Uploaded Documentation Archive
0.1.0 May 8, 2018 Go to the documentation of feather 0.1.0 Download feather 0.1.0 archive
0.0.6 Apr 10, 2018 Go to the documentation of feather 0.0.6 Download feather 0.0.6 archive
0.0.5 Apr 10, 2018 Go to the documentation of feather 0.0.5 Download feather 0.0.5 archive
0.0.4 Apr 10, 2018 Go to the documentation of feather 0.0.4 Download feather 0.0.4 archive
0.0.3 Apr 10, 2018 Go to the documentation of feather 0.0.3 Download feather 0.0.3 archive
0.0.2 Apr 4, 2018 Go to the documentation of feather 0.0.2 Download feather 0.0.2 archive
0.0.1 Apr 3, 2018 Go to the documentation of feather 0.0.1 Download feather 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
33
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
17
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0