fft 0.0.13

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 55

dart

An implementation of Cooley-Tukey. Also included are the windowing functions Hann and Hamming

Usage

A simple usage example:

import 'package:fft/fft.dart';

main() {
	   var data = [1.0, 0.0, -1.0, 0.0];
   var windowed = Window.Hann(data);
	   var fft = new FFT().Transform(windowed);
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

0.0.5

  • Corrected phase problem

0.0.6

  • Added FFT.TransformAsComplexPolar, ComplexPolar.invert()

0.0.7

  • Changed algorithm to use Complex rather than ComplexPolar

0.0.8

  • made WindowType visible

0.0.10

  • removed ComplexPolar and replaced with new Complex type

0.0.11

  • added inverse and conjugate()

0.0.12

  • bug fixes

0.0.13

  • added clone() method to complex numbers

0.0.14

  • moved complex numbers to new library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fft: "^0.0.13"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fft/fft.dart';
        
Version Uploaded Documentation Archive
0.0.13 Feb 13, 2017 Go to the documentation of fft 0.0.13 Download fft 0.0.13 archive
0.0.12 Feb 12, 2017 Go to the documentation of fft 0.0.12 Download fft 0.0.12 archive
0.0.11 Apr 4, 2016 Go to the documentation of fft 0.0.11 Download fft 0.0.11 archive
0.0.10 Apr 4, 2016 Go to the documentation of fft 0.0.10 Download fft 0.0.10 archive
0.0.9 Feb 22, 2016 Go to the documentation of fft 0.0.9 Download fft 0.0.9 archive
0.0.8 Oct 26, 2015 Go to the documentation of fft 0.0.8 Download fft 0.0.8 archive
0.0.7 Oct 22, 2015 Go to the documentation of fft 0.0.7 Download fft 0.0.7 archive
0.0.6 Oct 22, 2015 Go to the documentation of fft 0.0.6 Download fft 0.0.6 archive
0.0.5 Oct 20, 2015 Go to the documentation of fft 0.0.5 Download fft 0.0.5 archive
0.0.4 Oct 20, 2015 Go to the documentation of fft 0.0.4 Download fft 0.0.4 archive

All 13 versions...

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
21 / 100
Health:
Code health derived from static analysis. [more]
95 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
81 / 100
Overall score:
Weighted score of the above. [more]
55
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:fft/fft.dart.

Suggestions

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 5 hints.

    Run dartfmt to format lib/fft.dart.

    Run dartfmt to format lib/window.dart.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use fft.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
my_complex >=0.0.1 <0.1.0 0.0.4
Dev dependencies
test >=0.12.0 <0.13.0