firebase3 0.2.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 39

DEPRECATED: Dart wrapper library for the new Firebase

This library is now deprecated and moved to the official firebase-dart.

0.2.3

  • BREAKING This library is now deprecated and moved to firebase-dart.
  • Update to Firebase 3.6.2.
  • Support for custom OAuth parameters with GoogleAuthProvider.setCustomParameters(), FacebookAuthProvider.setCustomParameters(), GithubAuthProvider.setCustomParameters() and TwitterAuthProvider.setCustomParameters() methods.
  • AuthCredential now has the accessToken and secret (Twitter only) properties.
  • Added an implementation of simple, server access to Firebase realtime database via firebase_io.dart.

0.2.2

  • Update to Firebase 3.4.0.
  • Added isEqual() method for Query class.
  • Strong mode fixes.
  • More docs.

0.2.1

  • Input params validation for methods which work with JS types.
  • Fixes in the lib.
  • More documentation and tests.
  • Readme update with information on how to run tests and examples.

0.2.0

  • BREAKING Exposing only one top-level library: firebase.dart.
  • BREAKING ThenableReference and UploadTask are having future property to handle then() and catchError().
  • BREAKING CustomMetadata is now a Map.
  • BREAKING Storage APIs now expose Uri and DateTime instead of String where appropriate.
  • BREAKING Storage onStateChanged returns Stream<UploadTaskSnapshot>.
  • Updates and fixes in examples
  • Fixes in the lib

0.1.0

  • Initial version of library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase3: "^0.2.3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase3/firebase.dart';

import 'package:firebase3/firebase_io.dart';
        
Version Uploaded Documentation Archive
0.2.3 Dec 17, 2016 failed Download firebase3 0.2.3 archive
0.2.2 Oct 17, 2016 Go to the documentation of firebase3 0.2.2 Download firebase3 0.2.2 archive
0.2.1 Sep 5, 2016 Go to the documentation of firebase3 0.2.1 Download firebase3 0.2.1 archive
0.2.0 Aug 24, 2016 Go to the documentation of firebase3 0.2.0 Download firebase3 0.2.0 archive
0.1.0 Aug 8, 2016 Go to the documentation of firebase3 0.1.0 Download firebase3 0.1.0 archive
0.2.0-dev Aug 18, 2016 Go to the documentation of firebase3 0.2.0-dev Download firebase3 0.2.0-dev archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
21 / 100
Health:
Code health derived from static analysis. [more]
69 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
41 / 100
Overall score:
Weighted score of the above. [more]
39
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Error(s) in lib/firebase_io.dart: Target of URI doesn't exist: 'package:http/http.dart'.

Suggestions

  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Error(s) in lib/firebase_io.dart: Target of URI doesn't exist: 'package:http/http.dart'.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 22 errors 11 hints.

    Make sure that the imported libraries are not in conflict. Error(s) in lib/firebase_io.dart: Target of URI doesn't exist: 'package:http/http.dart'.

    Strong-mode analysis of lib/src/assets/assets.dart failed with the following error:

    line: 4 col: 8
    Target of URI doesn't exist: 'package:http/browser_client.dart'.

    Similar analysis of the following files failed:

    • lib/src/assets/assets_io.dart (error)
    • lib/src/auth.dart (error)
    • lib/src/database.dart (error)
    • lib/src/utils.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use firebase3.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.18.0 <2.0.0
browser >=0.10.0 <0.11.0 0.10.0+3
func >=0.1.0 <0.2.0 0.1.1 1.0.0
js >=0.6.0 <0.7.0 0.6.1
Dev dependencies
googleapis_auth ^0.2.3+5
http ^0.11.3
path ^1.3.9
test >=0.12.17 <0.13.0