firebase_dart 0.7.10

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 28

A pure Dart implementation of the Firebase client

Usage

A simple usage example:

import 'package:firebase_dart/firebase_dart.dart';

main() {
  var ref = new Firebase("https://n6ufdauwqsdfmp.firebaseio-demo.com/");

  ref.child("test").onValue.listen((e) {
    print(e.snapshot.val);
  });
}

Local database

Besides connecting to a remote firebase database, you can also create and work with a local in memory database.

var ref = new Firebase("mem://some.name/");

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.7.10

  • Dart 2 pre-release compatibility

0.7.9

  • add FirebaseApp and FirebaseDatabase classes
  • performance improvements
  • recover from connection closed by peer

0.7.8

  • Remove dart 2 only things

0.7.7

  • Fix issue ack making view incomplete

0.7.6

  • Remove delay on write operations with in-memory database

0.7.5

  • Fix bug concurrent modification with transactions

0.7.4

  • Fix order by grandchild
  • Resolve strong mode analysis warnings

0.7.3

  • Fix The method 'operationForChild' was called on null.

0.7.2

  • Fix not able to authenticate with database secret

0.7.1

  • Fix bug saving lists

0.7.0

  • Local memory database
  • bugfixes

0.6.0

  • improved performance by only listening to the most general query
  • bugfixes

0.5.7

  • fix handling merge when some new children are nil

0.5.6

  • fix child of empty datasnapshot

0.5.5

  • implement onChildChanged, onChildMoved, onChildRemoved and onChildAdded

0.5.4

  • fix hash of null in transactions

0.5.3

  • fix signature check when padded

0.5.2

  • fix decoding tokens not padded with =

0.5.1

  • fix redirects to host with port

0.5.0

  • Breaking signature of startAt/endAt
  • reconnect when connection broken
  • bugfixes
  • FirebaseToken class

0.4.1

  • handle messages split in multiple frames (issue #8)

0.4.0

  • browser support
  • strong mode

0.3.0

  • implement transactions
  • implement onDisconnect
  • bug fixes

0.2.1

  • relax dependency on crypto library to '>=0.9.2 <3.0.0'

0.2.0

  • implement auth revoke and listen revoke
  • implement startAt and endAt
  • remove failed operations

0.1.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_dart: ^0.7.10

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_dart/firebase_dart.dart';
  
Version Uploaded Documentation Archive
0.7.10 Jul 18, 2018 Go to the documentation of firebase_dart 0.7.10 Download firebase_dart 0.7.10 archive
0.7.9 Jul 12, 2018 Go to the documentation of firebase_dart 0.7.9 Download firebase_dart 0.7.9 archive
0.7.8 Apr 3, 2018 Go to the documentation of firebase_dart 0.7.8 Download firebase_dart 0.7.8 archive
0.7.7 Mar 31, 2018 Go to the documentation of firebase_dart 0.7.7 Download firebase_dart 0.7.7 archive
0.7.6 Mar 28, 2018 Go to the documentation of firebase_dart 0.7.6 Download firebase_dart 0.7.6 archive
0.7.5 Mar 19, 2018 Go to the documentation of firebase_dart 0.7.5 Download firebase_dart 0.7.5 archive
0.7.4 Mar 19, 2018 Go to the documentation of firebase_dart 0.7.4 Download firebase_dart 0.7.4 archive
0.7.3 Jan 12, 2018 Go to the documentation of firebase_dart 0.7.3 Download firebase_dart 0.7.3 archive
0.7.2 Apr 11, 2017 Go to the documentation of firebase_dart 0.7.2 Download firebase_dart 0.7.2 archive
0.7.1 Apr 10, 2017 Go to the documentation of firebase_dart 0.7.1 Download firebase_dart 0.7.1 archive

All 27 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
56
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.14.0 <2.0.0