firebase_dart_ui 0.0.2

  • Installing
  • Versions
  • 66


A dart wrapper for FirebaseUI, a Javascript library that provides sign on flows. This library provides an Angular Dart wrapper around FirebaseUI.

A demo app is hosted online here

The Angular component <firebase-auth-ui> handles Firebase Authentication for your application.

The component is visible when the user has not been authenticated. It presents a dialog with the various social login and email providers that have been configured. Once the user has authenticated, the components display attribute is set to none. Embed this component on your landing page for your SPA application.


You must add these lines to your index.html <head> section:

<script src=""></script>
<script src=""></script>
<link type="text/css" rel="stylesheet" href="" />

See the example/ application.

Running the demo

With DDC:

cd example
pub serve
# open localhost:8080

To use your our own Firebase project to test, you must edit main.dart and enter in your project credentials. Also edit example/.firebaserc and enter your project name.

Build and deploy the example:

cd example
pub build
firebase deploy

Known Issues

  • The provider implementations need to be fleshed out (phone provider, for example)
  • The signInSuccess callback does not get invoked. JS interop issue. Suggestions welcome.



  • Initial version, created by Stagehand

1. Depend on it

Add this to your package's pubspec.yaml file:

  firebase_dart_ui: "^0.0.2"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:firebase_dart_ui/firebase_dart_ui.dart';
Version Uploaded Documentation Archive
0.0.2 Feb 15, 2018 Go to the documentation of firebase_dart_ui 0.0.2 Download firebase_dart_ui 0.0.2 archive
0.0.1 Jan 7, 2018 Go to the documentation of firebase_dart_ui 0.0.1 Download firebase_dart_ui 0.0.1 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 15, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
41 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
76 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: unsure

Error(s) prevent platform classification.


  • Fix dependencies in pubspec.yaml.

    Running pub upgrade failed with the following output:

    ERR: Package firebase_dart_ui requires SDK version >=2.0.0-dev.23.0 <2.0.0 but the current SDK is 2.0.0-dev.20.0.
  • Fix platform conflicts.

    Make sure none of the libraries use mutually exclusive dependendencies.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 1 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use firebase_dart_ui.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.23.0 <2.0.0