A demo app is hosted online here
The Angular component
Firebase Authentication for your application.
The component is visible when the user has not been authenticated. It presents a dialog with
the various social login and email providers that have been configured. Once the user
has authenticated, the components display attribute is set to
none. Embed this component
on your landing page for your SPA application.
You must add these lines to your index.html
<script src="https://www.gstatic.com/firebasejs/4.8.1/firebase.js"></script> <script src="https://cdn.firebase.com/libs/firebaseui/2.5.1/firebaseui.js"></script> <link type="text/css" rel="stylesheet" href="https://cdn.firebase.com/libs/firebaseui/2.5.1/firebaseui.css" />
See the example/ application.
cd example pub serve # open localhost:8080
To use your our own Firebase project to test, you must edit main.dart and enter in your project credentials. Also edit example/.firebaserc and enter your project name.
Build and deploy the example:
cd example pub build firebase deploy
Add this to your package's pubspec.yaml file:
dependencies: firebase_dart_ui: "^0.0.2"
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.2||Feb 15, 2018|
|0.0.1||Jan 7, 2018|
We analyzed this package, and provided a score, details, and suggestions below.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: unsure
Error(s) prevent platform classification.
Fix dependencies in
pub upgradefailed with the following output:
ERR: Package firebase_dart_ui requires SDK version >=2.0.0-dev.23.0 <2.0.0 but the current SDK is 2.0.0-dev.20.0.
Fix platform conflicts.
Make sure none of the libraries use mutually exclusive dependendencies.
Fix issues reported by
dartanalyzerreported 1 error(s) and 0 warning(s).
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
None of the files in your
example/directory matches a known example patterns. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=2.0.0-dev.23.0 <2.0.0|