firebase_list 0.0.1

  • README.md
  • Installing
  • Versions
  • 38

FirebaseList

A Dart List class synchronized to a Firebase reference

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_list: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_list/firebase_list.dart';
        
Version Uploaded Documentation Archive
0.0.1 Jul 25, 2016 Go to the documentation of firebase_list 0.0.1 Download firebase_list 0.0.1 archive
0.0.0 Jul 6, 2016 Go to the documentation of firebase_list 0.0.0 Download firebase_list 0.0.0 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
38 / 100
Overall score:
Weighted score of the above. [more]
38

Platforms

Detected platforms: web, other

Primary library: package:firebase_list/firebase_list.dart with components: js.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use firebase_list.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
collection_helpers ^0.9.1 0.9.1 0.9.2
firebase ^0.6.3 0.6.6+3 4.3.1
Transitive dependencies
async 2.0.3
charcode 1.1.1
collection 1.14.5
convert 2.0.1
crypto 2.0.2+1
http 0.11.3+16
http_parser 3.1.1
path 1.5.1
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
logging ^0.11.2
logging_handlers ^0.8.0
test ^0.12.4