firebase_ui 0.0.19

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new75

firebase_ui #

Build Status pub package

Fork of https://pub.dartlang.org/packages/flutter_firebase_ui

Old package wasnt being maintained so i created this one to update;

firebase_ui is a library that help you to quickly implement firebase authentication. It provider UI for the common identity providers, Facebook, Google, Twitter and email.

Note: this plugin use firebase_auth you must configure it as describe here.

screenshot

Show firebase ui example.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.19] - 19/12/2018

  • update dependencies
  • added show/hide app bar

[0.0.13] - 19/12/2018

  • update dependencies
  • add twitter

[0.0.12] - 27/09/2018

  • after trouble sign in pop

[0.0.11] - 27/09/2018

  • add function signOutProviders

[0.0.10] - 26/09/2018

  • fixed empty null on Providers
  • allow for usage with landscape orientation

[0.0.9] - 07/09/2018

  • add mail verification option

[0.0.8] - 17/07/2018

  • improve UI

[0.0.7] - 04/07/2018

  • fixe sign in with mail

[0.0.6] - 30/05/2018

  • improve show dialog error

[0.0.5] - 29/05/2018

  • show error occured on unknown errors
  • display email if no displayName (example)
  • secure providers test, firebase_auth behavior change
  • pop sign up !

[0.0.4] - 09/05/2018

  • Upgrade to Google Services 3.2.1 and Google Sign In 3.0.3

[0.0.3] - 23/03/2018

  • dart 2 fix

[0.0.2] - 20/03/2018

  • improve ui
  • change firebase_auth version

[0.0.1] - 19/03/2018

  • initial release

example/README.md

firebase_ui #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_ui: ^0.0.19

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_ui/email_view.dart';
import 'package:firebase_ui/flutter_firebase_ui.dart';
import 'package:firebase_ui/l10n/localization.dart';
import 'package:firebase_ui/l10n/translations.dart';
import 'package:firebase_ui/login_view.dart';
import 'package:firebase_ui/password_view.dart';
import 'package:firebase_ui/sign_up_view.dart';
import 'package:firebase_ui/trouble_signin.dart';
import 'package:firebase_ui/utils.dart';
  
Version Uploaded Documentation Archive
0.0.19 Apr 6, 2019 Go to the documentation of firebase_ui 0.0.19 Download firebase_ui 0.0.19 archive
0.0.18 Apr 6, 2019 Go to the documentation of firebase_ui 0.0.18 Download firebase_ui 0.0.18 archive
0.0.17 Apr 6, 2019 Go to the documentation of firebase_ui 0.0.17 Download firebase_ui 0.0.17 archive
0.0.16 Apr 5, 2019 Go to the documentation of firebase_ui 0.0.16 Download firebase_ui 0.0.16 archive
0.0.15 Apr 5, 2019 Go to the documentation of firebase_ui 0.0.15 Download firebase_ui 0.0.15 archive
0.0.14 Apr 5, 2019 Go to the documentation of firebase_ui 0.0.14 Download firebase_ui 0.0.14 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
62
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
75
Learn more about scoring.

We analyzed this package on Apr 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
firebase_auth ^0.8.4 0.8.4+5
flutter 0.0.0
flutter_facebook_login ^2.0.0 2.0.0
flutter_twitter_login ^1.1.0 1.1.0
google_sign_in ^4.0.1+3 4.0.1+3
Transitive dependencies
collection 1.14.11
firebase_core 0.3.4
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test