fit_image 0.1.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 67

fit_image

A Image Widget that can be used with BoxFit.

screenshot

https://raw.githubusercontent.com/CaiJingLong/Flutter-FixImage/master/img/1.gif

use

import fit_image;

import 'package:flutter/widgets.dart';

Widget image = new FixImage(
  child: new Image.asset("img/flutter-mark-square-100.png"), // your Image
  fit: BoxFit.cover, 
);

install

  1. Depend on it Add this to your package's pubspec.yaml file:
dependencies:
  fit_image: "^0.1.2"
  1. Install it You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

[0.1.2]

ui.Image will call dispose()

[0.1.1]

update readme

[0.1.0]

first version init commit and

example/main.dart

import 'package:fit_image/fit_image.dart';
import 'package:flutter/material.dart';

class Sample extends StatefulWidget {
  @override
  _SampleState createState() => new _SampleState();
}

class _SampleState extends State<Sample> {
  @override
  Widget build(BuildContext context) {
    return new Scaffold(
      appBar: new AppBar(
        title: new Text('FixImage'),
      ),
      body: new ListView.builder(
        itemBuilder: _buildChild,
        itemCount: BoxFit.values.length,
      ),
    );
  }

  Widget _buildChild(BuildContext context, int index) {
    var fit = BoxFit.values[index];

    return new Column(
      children: <Widget>[
        new SizedBox(
          width: 100.0,
          height: 120.0,
          child: new FitImage(
            child: new Image.asset("img/flutter-mark-square-100.png"),
            fit: fit,
          ),
        ),
        new Text('$fit'),
      ],
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fit_image: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fit_image/fit_image.dart';
  
Version Uploaded Documentation Archive
0.1.2 Jun 5, 2018 Go to the documentation of fit_image 0.1.2 Download fit_image 0.1.2 archive
0.1.1 May 12, 2018 Go to the documentation of fit_image 0.1.1 Download fit_image 0.1.1 archive
0.1.0 May 11, 2018 Go to the documentation of fit_image 0.1.0 Download fit_image 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
41
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Sep 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.3
  • Flutter: 0.8.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Fix lib/fit_image.dart.

Analysis of lib/fit_image.dart reported 1 hint:

line 133 col 43: 'OK' is deprecated and shouldn't be used.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test