fixedwidth 0.0.1

  • Example
  • Installing
  • Versions
  • 46


A library for working with fixed width files in dart


A simple usage example:

    // more to come
    import 'package:fixedwidth/fixedwidth.dart';

    main() {
      var awesome = new Awesome();

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Initial version, created by Stagehand


import 'package:fixedwidth/fixedwidth.dart';

main() {
  var awesome = new Awesome();
  print('awesome: ${awesome.isAwesome}');

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  fixedwidth: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:fixedwidth/fixedwidth.dart';
Version Uploaded Documentation Archive
0.3.1 Apr 11, 2018 Go to the documentation of fixedwidth 0.3.1 Download fixedwidth 0.3.1 archive
0.3.0 Mar 16, 2018 Go to the documentation of fixedwidth 0.3.0 Download fixedwidth 0.3.0 archive
0.2.0 Mar 13, 2018 Go to the documentation of fixedwidth 0.2.0 Download fixedwidth 0.2.0 archive
0.1.0 Mar 9, 2018 Go to the documentation of fixedwidth 0.1.0 Download fixedwidth 0.1.0 archive
0.0.1 Mar 4, 2018 Go to the documentation of fixedwidth 0.0.1 Download fixedwidth 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.69.0
  • pana: 0.11.7


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:fixedwidth/fixedwidth.dart.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
Dev dependencies
test ^0.12.0