flat_icons_flutter 1.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 78

flat_icons_flutter #

The Flat Icons Icon pack available as set of Flutter Icons.

Based on Flat Icons Includes all free icons:

  • Essentials
  • Social
  • Arrows set
  • Many and more, get some coffee and explore the beauty of the categories

Installation #

In the dependencies: section of your pubspec.yaml, add the following line:

  flat_icons_flutter: <latest_version>

Usage #

import 'package:flat_icons_flutter/flat_icons_flutter.dart';

class MyWidget extends StatelessWidget {
  Widget build(BuildContext context) {
    return new IconButton(
      // Use the FlatIcons class for the IconData
      icon: new Icon(FlatIcons.home),
      onPressed: () { print("Pressed"); }
     );
  }
}

Example #

View the Flutter app in the example directory to see all the available FlatIcons.

Contributor #

  • Duncan Adjei

flat_icons_flutter 1.0.1 #

initial release. with Essential flat_icons #

flat_icons_flutter 1.0.2 #

# Added: 
    * Arrow sets 
    * Social media sets
    

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flat_icons_flutter: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flat_icons_flutter/flat_icons_flutter.dart';
  
Version Uploaded Documentation Archive
1.0.2 Mar 21, 2019 Go to the documentation of flat_icons_flutter 1.0.2 Download flat_icons_flutter 1.0.2 archive
1.0.1 Mar 20, 2019 Go to the documentation of flat_icons_flutter 1.0.1 Download flat_icons_flutter 1.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
68
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Apr 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

589 out of 589 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flat_icons_flutter.dart.

Run flutter format to format lib/flat_icons_flutter.dart.

Format lib/icon_data.dart.

Run flutter format to format lib/icon_data.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flat_icons_flutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test