flatten 1.0.0

  • README.md
  • Installing
  • Versions
  • 50


version 1.0.0 build status

Optimizes a router by condensing all its routes into one level. This only works with package:angel_route.

package:angel_route is an ultra-powerful router that works across all platforms. It supports nested groups, and an advanced middleware system. The caveat is, route groups and middleware exist at different levels within the hierarchy when nested. Flattening a router condenses all routes into one level, and inlines route handlers, so that paths can be resolved much faster.

The Angel framework uses a flattened router in production mode to optimize servers.


In your pubspec.yaml:

  angel_route: ^1.0.0
  flatten: ^1.0.0


import 'package:angel_route/angel_route.dart'; import 'package:flatten/flatten.dart';

var flattened = flatten(myRouter);


This package doesn't actually modify the existing router; instead, it creates a new one. Routes adding to the original router after flattening will not be present in the new router.

1. Depend on it

Add this to your package's pubspec.yaml file:

  flatten: "^1.0.0"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flatten/flatten.dart';
Version Uploaded Documentation Archive
1.0.0 Mar 31, 2017 Go to the documentation of flatten 1.0.0 Download flatten 1.0.0 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
7 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
80 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:flatten/flatten.dart.


  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use flatten.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0
angel_route ^1.0.0 1.0.8 2.0.5
Dev dependencies
test ^0.12.0