flickr 0.0.1

  • Installing
  • Versions
  • 47


Dartlang wrapper for flickr API calls.


In your pubspec.yaml:




For tests to pass, set FLICKR_API_KEY obtained from request api key in your system variables:

$ export FLICKR_API_KEY="..."

Then run:

$ pub run test


import 'package:shelf/shelf.dart' as shelf;
import 'package:shelf/shelf_io.dart' as io;
import 'package:flickr/flickr_shelf.dart' as flickr;

main() {
  var port = 9999;
  var apiKey = Platform.environment['FLICKR_API_KEY'];
  var f = new flickr.Flickr(apiKey);
  var handler = const shelf.Pipeline()

  var server = await io.serve(handler, '', port);


import 'package:flickr/flickr_client.dart' as flickr;

main() async {
  var rootUrl = 'host url without http or https'; // example:
  var api = new flickr.FlickrApi(rootUrl);

  var result ='cats', 1);
  var photos = result.entries;
  var photo = photos.first;
  var smallPhotoUri = photo.smallSquareUri;



  • Initial version, created by Stagehand

1. Depend on it

Add this to your package's pubspec.yaml file:

  flickr: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flickr/flickr.dart';
Version Uploaded Documentation Archive
0.0.1 Mar 23, 2017 Go to the documentation of flickr 0.0.1 Download flickr 0.0.1 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 14, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
92 / 100
Reflects how tidy and up-to-date the package is. [more]
95 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:flickr/flickr.dart.


  • Fix lib/src/search.dart.

    Strong-mode analysis of lib/src/search.dart failed with the following error:

    line: 135 col: 25
    A value of type 'List<String>' can't be assigned to a variable of type 'List<int>'.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 1 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use flickr.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
http >=0.11.3+9 <0.12.0 0.11.3+16
shelf >=0.6.7+2 <0.7.0 0.6.8 0.7.2
shelf_route >=0.14.3 <0.15.0 0.14.3
Transitive dependencies
async 1.13.3 2.0.4
charcode 1.1.1
collection 1.14.5
concepts 0.2.0
either 0.1.8
http_parser 3.1.1
matcher 0.12.1+4
option 1.2.0
path 1.5.1
quiver 0.25.0 0.28.0
shelf_path 0.1.8
source_span 1.4.0
stack_trace 1.9.2
stream_channel 1.6.3
string_scanner 1.0.2
typed_data 1.1.5
uri 0.11.1
utf 0.9.0+4
Dev dependencies
shelf_cors >=0.2.1 <0.3.0
test >=0.12.0 <0.13.0