flist 0.1.4

  • README.md
  • Installing
  • Versions
  • 0

flist

Flutter page list

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flist: ^0.1.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flist/list_builder.dart';
import 'package:flist/page_list.dart';
import 'package:flist/paginator/length_aware_paginator.dart';
import 'package:flist/paginator/paginator.dart';
  
Version Uploaded Documentation Archive
0.1.4 Mar 9, 2018 Go to the documentation of flist 0.1.4 Download flist 0.1.4 archive
0.1.3 Mar 9, 2018 Go to the documentation of flist 0.1.3 Download flist 0.1.3 archive
0.1.2 Mar 9, 2018 Go to the documentation of flist 0.1.2 Download flist 0.1.2 archive
0.1.1 Mar 9, 2018 Go to the documentation of flist 0.1.1 Download flist 0.1.1 archive
0.1.0 Mar 9, 2018 Go to the documentation of flist 0.1.0 Download flist 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0