flown 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 51

pub package

flown #

A utility for cloning Flutter apps with local dependencies

flown will take a url and search for flutter apps. It will then recursively scan each app's pubspec.yaml for local dependencies anywhere in the directory hierarchy, create a new project and install local dependencies.

license.

Usage #

A simple usage example:

flown --arch vanilla --name vanilla_project

General Usage

   $ flown --help
   usage: flown [--help] --arch <arch name> --name <project name>
   
   sample usage: flown --arch vanilla --name vanilla_project
   
   --arch=<arch name>             Available architectures:
   
         [bloc_flutter]           BloC pattern with Firestore backend.
         [built_redux]            Redux pattern with generated code.
         [firestore_redux]        Redux pattern with Firestore backend.
         [inherited_widget]       Inherited Widget pattern.
         [mvi_flutter]            MVI pattern with Firestore backend.
         [mvu]                    MVU pattern.
         [redurx]                 ReduRx pattern.
         [redux]                  Redux pattern.
         [scoped_model]           Scoped Model pattern.
         [simple_bloc_flutter]    Simple BloC pattern with Firestore backend.
         [vanilla]                Standard Flutter pattern.
   
   --name=<project name>          Name of new project.
   --help                         Display this help information.

Installation #

pub global activate flown

Features and bugs #

Currently restricted to using apps found on https://github.com/brianegan/flutter_architecture_examples.

Please file feature requests and bugs at the issue tracker.

0.0.1 #

  • Initial version

example/flown_example.dart

import 'package:flown/flown.dart';

main() {
  var awesome = new Awesome();
  print('awesome: ${awesome.isAwesome}');
}

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate flown

2. Use it

The package has the following executables:


$ flown

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flown: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flown/flown.dart';
  
Version Uploaded Documentation Archive
0.0.3 Oct 31, 2018 Go to the documentation of flown 0.0.3 Download flown 0.0.3 archive
0.0.2 Oct 30, 2018 Go to the documentation of flown 0.0.2 Download flown 0.0.2 archive
0.0.1 Oct 30, 2018 Go to the documentation of flown 0.0.1 Download flown 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
15
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:flown/flown.dart.

Health suggestions

Fix bin/flown.dart. (-0.50 points)

Analysis of bin/flown.dart reported 1 hint:

line 81 col 7: Use isEmpty instead of length

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.55.0 <3.0.0
args ^1.5.0 1.5.1
yaml ^2.1.15 2.1.15
yamlicious ^0.1.0 0.1.0
Transitive dependencies
charcode 1.1.2
collection 1.14.11
matcher 0.12.4
meta 1.1.7
path 1.6.2
quiver 2.0.1
source_span 1.5.4
stack_trace 1.9.3
string_scanner 1.0.4
term_glyph 1.1.0
Dev dependencies
test ^1.3.4