flutter_3d_obj 0.0.5

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 79

flutter_3d_obj

A flutter package to render wavefront obj files on a canvas.

Usage

To use this package, add flutter_3d_obj to your pubspec.yaml file. Then import the package to use it.

Example Usage

The following example basic usage of package.

...
child: new Object_3D(size:'/size of canvas/',
                    path:'/path of file/',
                    asset: true'/set true to load file from assets/'),
...

If SD-card path provided, ensure SD-card permissions are available.

Example

To run the example.

* git clone https://github.com/hemanthrajv/flutter_3d_obj.git
* cd /path to cloned dir/
* cd example
* flutter run

Screenshot:

Failed to load Screenshot

Built With

  • Flutter - A framework for building crossplatform mobile applications with native look and feel.

Author

Hemanth Raj LinkedIn

Getting Started

For help getting started with Flutter, view online documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

[0.0.2] - Updated to provide zoom, angleX, angleY and angleZ args.

[0.0.3] - Added Example

[0.0.4] - Dart 2 support

[0.0.5] - Breaking Change

  • changed the class name from Object_3D to Object3D

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter_3d_obj/flutter_3d_obj.dart';

void main() {
  runApp(new MyApp());
}

class MyApp extends StatelessWidget {

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Flutter 3D Demo',
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text("Flutter 3D"),
        ),
        body:new Center(
              child: new Object3D(size: const Size(400.0, 400.0),path: "assets/file.obj",asset:true),
            ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_3d_obj: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_3d_obj/flutter_3d_obj.dart';
  
Version Uploaded Documentation Archive
0.0.5 Sep 19, 2018 Go to the documentation of flutter_3d_obj 0.0.5 Download flutter_3d_obj 0.0.5 archive
0.0.4 Sep 19, 2018 Go to the documentation of flutter_3d_obj 0.0.4 Download flutter_3d_obj 0.0.4 archive
0.0.3 Sep 10, 2017 Go to the documentation of flutter_3d_obj 0.0.3 Download flutter_3d_obj 0.0.3 archive
0.0.2 Sep 10, 2017 Go to the documentation of flutter_3d_obj 0.0.2 Download flutter_3d_obj 0.0.2 archive
0.0.1 Sep 10, 2017 Go to the documentation of flutter_3d_obj 0.0.1 Download flutter_3d_obj 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
63
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4
  • Flutter: 0.9.5

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/flutter_3d_obj.dart. (-1 points)

Analysis of lib/flutter_3d_obj.dart reported 2 hints:

line 136 col 10: The value of the field '_translation' isn't used.

line 299 col 9: The value of the local variable 'z' isn't used.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
meta ^1.1.1 1.1.6
vector_math ^2.0.5 2.0.8
Transitive dependencies
collection 1.14.11
sky_engine 0.0.99
typed_data 1.1.6