flutter_add_calendar 0.0.3

  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new65

0.0.1

  • TODO: Describe initial release.

example/README.md

flutter_add_calendar_example

Demonstrates how to use the flutter_add_calendar plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_add_calendar: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_add_calendar/flutter_add_calendar.dart';
  
Version Uploaded Documentation Archive
0.0.3 Nov 10, 2018 Go to the documentation of flutter_add_calendar 0.0.3 Download flutter_add_calendar 0.0.3 archive
0.0.1 Nov 6, 2018 Go to the documentation of flutter_add_calendar 0.0.1 Download flutter_add_calendar 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
45
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Maintain README.md. (-30 points)

Readme should inform others about your project, what it does, and how they can use it.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8