flutter_amazon_s3 0.0.9

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 72

flutter_amazon_s3

Amazon S3 plugin for Flutter

Unofficial Amazon S3 plugin written in Dart for Flutter.

Usage

To use this plugin, add flutter_amazon_s3 as a dependency in your pubspec.yaml file.

dependencies:
  flutter_amazon_s3: '^0.0.9'

Example

import 'package:flutter_amazon_s3/flutter_amazon_s3.dart';

String uploadedImageUrl = await FlutterAmazonS3.uploadImage(
          _image.path, BUCKET_NAME, IDENTITY_POOL_ID);

Installation

Android

No configuration required - the plugin should work out of the box.

iOS

No configuration required - the plugin should work out of the box.

Authors

Android version written by Tony Darko
IOS version written by Vladislav Blago

0.0.1

  • Init with basic functional for Android and IOS

0.0.2

  • Try to correct configuration

0.0.3

  • Try to correct configuration 2

0.0.4

  • Make code a little universal

0.0.5

  • Fixes android code.....

0.0.6

  • Android version works as well, testing IOS

0.0.7

  • Android version works as well. Next step - IOS

0.0.8

  • IOS version works as well. Added Documentation.

0.0.9

  • Some fixes in docs

example/README.md

flutter_amazon_s3_example

Demonstrates how to use the flutter_amazon_s3 plugin.

Getting Started

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_amazon_s3: ^0.0.9

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_amazon_s3/flutter_amazon_s3.dart';
  
Version Uploaded Documentation Archive
0.0.9 Dec 23, 2018 Go to the documentation of flutter_amazon_s3 0.0.9 Download flutter_amazon_s3 0.0.9 archive
0.0.8 Dec 23, 2018 Go to the documentation of flutter_amazon_s3 0.0.8 Download flutter_amazon_s3 0.0.8 archive
0.0.7 Dec 21, 2018 Go to the documentation of flutter_amazon_s3 0.0.7 Download flutter_amazon_s3 0.0.7 archive
0.0.6 Dec 20, 2018 Go to the documentation of flutter_amazon_s3 0.0.6 Download flutter_amazon_s3 0.0.6 archive
0.0.5 Dec 20, 2018 Go to the documentation of flutter_amazon_s3 0.0.5 Download flutter_amazon_s3 0.0.5 archive
0.0.4 Dec 20, 2018 Go to the documentation of flutter_amazon_s3 0.0.4 Download flutter_amazon_s3 0.0.4 archive
0.0.3 Dec 20, 2018 Go to the documentation of flutter_amazon_s3 0.0.3 Download flutter_amazon_s3 0.0.3 archive
0.0.2 Dec 20, 2018 Go to the documentation of flutter_amazon_s3 0.0.2 Download flutter_amazon_s3 0.0.2 archive
0.0.1 Dec 20, 2018 Go to the documentation of flutter_amazon_s3 0.0.1 Download flutter_amazon_s3 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
57
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
72
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8