flutter_amplitude 0.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 68

Flutter implementation of Amplitude SDK

Getting Started

To use this plugin, add flutter_amplitude as a dependency in your pubspec.yaml file.

Example

    FlutterAmplitude.init("your_apy_key", true);
    FlutterAmplitude.addGeneralProperties({'generalParameterKey': 'generalParameterValue'});
    FlutterAmplitude.setUserId("info@sample.com");
    FlutterAmplitude.setUserProperties({'userParameterKey': 'userParameterValue'});
    FlutterAmplitude.logEvent("EVENT_KEY", {'eventParameterKey': 'eventParameterValue'});

License

Copyright 2018 Miguel Catalan BaƱuls

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

	http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.

[0.0.3] - 09 June 2018

  • Improve example

[0.0.2] - 09 June 2018

  • Fix exception when no parameter is added to an event

[0.0.1] - 03 June 2018

  • Initial release

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:flutter_amplitude/flutter_amplitude.dart';

void main() {
  runApp(new MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {

  @override
  initState() {
    super.initState();
    init();
  }

  init() async {

    FlutterAmplitude.init("your_apy_key", true);
    FlutterAmplitude.addGeneralProperties({'generalParameterKey': 'generalParameterValue'});
    FlutterAmplitude.setUserId("info@sample.com");
    FlutterAmplitude.setUserProperties({'userParameterKey': 'userParameterValue'});
    FlutterAmplitude.logEvent("EVENT_KEY", {'eventParameterKey': 'eventParameterValue'});

    if (!mounted) return;
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Plugin example app'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_amplitude: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_amplitude/flutter_amplitude.dart';
  
Version Uploaded Documentation Archive
0.0.3 Jun 9, 2018 Go to the documentation of flutter_amplitude 0.0.3 Download flutter_amplitude 0.0.3 archive
0.0.2 Jun 9, 2018 Go to the documentation of flutter_amplitude 0.0.2 Download flutter_amplitude 0.0.2 archive
0.0.1 Jun 3, 2018 Go to the documentation of flutter_amplitude 0.0.1 Download flutter_amplitude 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
50
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
65
Overall:
Weighted score of the above. [more]
68
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4
  • Flutter: 0.9.5

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-5 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8