flutter_auth_base 0.1.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new56

flutter_auth_base

A flutter package that provides a base level set of classes to implement authentication controls

Note: This package is still in development

Usage

On its own this package does not do anything, but it is required as a dependency for other authentication packages. Currently the packages supported are:

flutter_auth_firebase

In adition to the dependency that package has on this one, the flutter_auth_starter also requires it.

Issues and Feedback

Please create an issue to provide feedback or an issue.

0.1.0 - 30 April 2018

  • Initial Release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_auth_base: "^0.1.3"

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:flutter_auth_base/flutter_auth_base.dart';
  
Version Uploaded Documentation Archive
0.1.3 May 19, 2018 Go to the documentation of flutter_auth_base 0.1.3 Download flutter_auth_base 0.1.3 archive
0.1.2 May 19, 2018 Go to the documentation of flutter_auth_base 0.1.2 Download flutter_auth_base 0.1.2 archive
0.1.1 Apr 30, 2018 Go to the documentation of flutter_auth_base 0.1.1 Download flutter_auth_base 0.1.1 archive
0.1.0 Apr 30, 2018 Go to the documentation of flutter_auth_base 0.1.0 Download flutter_auth_base 0.1.0 archive

Analysis

We analyzed this package on May 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.54.0
  • pana: 0.10.6
  • Flutter: 0.4.4

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
12 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
56
Learn more about scoring.

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use flutter_auth_base.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.6 1.14.9
meta 1.1.5
sky_engine 0.0.99
typed_data 1.1.5
vector_math 2.0.6 2.0.7
Dev dependencies
flutter_test