flutter_auth_firebase 0.2.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new58

flutter_auth_firebase

This package is a wrapper to FlutterFire package so that it can be used with the Authentication Starter project

https://pub.dartlang.org/packages/flutter_auth_firebase

Setup

As a prerequisite to using firebase authentication you need to follow the instruction provided by the FlutterFire package.

At a minumum the dependencies required are:

Implement

Example code of using the package

The Google provider is from https://github.com/aqwert/flutter_auth_firebase_google

Imports:

import 'package:flutter_auth_base/flutter_auth_base.dart';
import 'package:flutter_auth_firebase/flutter_auth_firebase.dart';
AuthService createFirebaseAuthService() {
  var authService = new FirebaseAuthService();
  authService.authProviders.addAll([
    new FirebaseEmailProvider(service: authService),
    new FirebaseGoogleProvider(service: authService)
  ]);
  authService.linkProviders.addAll([
    new FirebaseEmailProvider(service: authService),
    new FirebaseGoogleProvider(service: authService)
  ]);

  return authService;
}

.authProviders

These are the authentication providers that are supported by the application and need to be set within the Firebase console. The ones supported by this package are:

  • Email with Password
  • Google Signin

.linkProviders

These represent the authenticaton providers that allow linking or connecting multiple accounts together which is supported by Firebase

.preAuthPhotoProvider, .postAuthPhotoProvider

Additionally the authService.preAuthPhotoProvider and/or authService.postAuthPhotoProvider can be configured to return a profile picture. See the flutter_auth_starter project for details.

TODO

  • [x] Google provider
  • [ ] Twitter provider
  • [ ] Facebook provider
  • [ ] Anonymous Signin
  • [ ] Passwordless signin
  • [ ] Verification by phone

Issues and Feedback

Since this is based on the FlutterFire package there are some things not yet implemented in order for this package to be supported.

Please create an issue to provide feedback or an issue.

[0.1.0] - 10 July 2018

  • Removed Google signin as a dependency. This is now a separate project

[0.1.0] - 29 May 2018

  • Firebase authentication with Email and Google signin

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_auth_firebase: "^0.2.0"

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:flutter_auth_firebase/flutter_auth_firebase.dart';
  
Version Uploaded Documentation Archive
0.2.0 Jul 10, 2018 Go to the documentation of flutter_auth_firebase 0.2.0 Download flutter_auth_firebase 0.2.0 archive

Analysis

We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3
  • Flutter: 0.5.4

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
17 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
58
Learn more about scoring.

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use flutter_auth_firebase.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0
firebase_auth ^0.5.10 0.5.12
flutter 0.0.0
flutter_auth_base ^0.1.5 0.1.5
Transitive dependencies
collection 1.14.6 1.14.10
meta 1.1.5
sky_engine 0.0.99
typed_data 1.1.5
vector_math 2.0.6 2.0.7
Dev dependencies
flutter_test