flutter_barcode_scanner 0.0.6

  • README.md
  • Example
  • Installing
  • Versions
  • new81

flutter_barcode_scanner #

A plugin for Flutter apps that adds barcode scanning support on both Android and iOS.

pub package

Demo gif

Try example #

Just clone the repository, open the project in Android Studio/ VS Code, open pubspec.yaml and click on Packages get. Connect device and hit run. To run on iPhone you need to run from Xcode first time and just make pod install in example/ios.

Getting Started #

Follow the steps for Android and iOS

Android #

⚡ Don't worry, you don't need to do anything.

iOS #

Deployment target : 10 Swift Version : 4.2

As iOS code is written in Swift so you need to convert your existing iOS codebase to swift (or if you are creating a new project from Android Studio make sure to check Include Swift support for iOS code.) To do that you can create a new project with same name in different location and then just copy iOS folder to existing.(if any changes made before make sure to add these in iOS(swift)). After making codebase in swift make sure that the Swift version is 4.2 as the code for iOS is written in Swift 4.2. To use on iOS, open the Xcode and add camera usage description in Info.plist.

<string>Camera permission is required for barcode scanning.</string>

How to use ? #

After making the changes in Android ans iOS add flutter_barcode_scanner to pubspec.yaml

  flutter_barcode_scanner: ^0.0.6
  1. You need to import the package first.

    import 'package:flutter_barcode_scanner/flutter_barcode_scanner.dart';

  2. Then use the scanBarcode method to access barcode scanning.

    String barcodeScanRes = await FlutterBarcodeScanner.scanBarcode(COLOR_CODE);

Here in scanBarcode(COLOR_CODE) you can pass hex-color which is the color of line in barcode overlay.

0.0.5 #

  • Bug fixes and improvements

0.0.5 #

  • Added support for Android X

0.0.4 #

  • Bug fixes and improvements

0.0.3 #

  • Added Android Support for 16 and above
  • Minor changes and bug fixes

0.0.2 #

  • Minor bug fixes and improvements

0.0.1 #

  • Initial release.


flutter_barcode_scanner_example #

Demonstrates how to use the flutter_barcode_scanner plugin.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_barcode_scanner: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_barcode_scanner/flutter_barcode_scanner.dart';
Version Uploaded Documentation Archive
0.0.6 Mar 23, 2019 Go to the documentation of flutter_barcode_scanner 0.0.6 Download flutter_barcode_scanner 0.0.6 archive
0.0.5 Mar 23, 2019 Go to the documentation of flutter_barcode_scanner 0.0.5 Download flutter_barcode_scanner 0.0.5 archive
0.0.4 Mar 12, 2019 Go to the documentation of flutter_barcode_scanner 0.0.4 Download flutter_barcode_scanner 0.0.4 archive
0.0.3 Mar 11, 2019 Go to the documentation of flutter_barcode_scanner 0.0.3 Download flutter_barcode_scanner 0.0.3 archive
0.0.2 Mar 8, 2019 Go to the documentation of flutter_barcode_scanner 0.0.2 Download flutter_barcode_scanner 0.0.2 archive
0.0.1 Mar 8, 2019 Go to the documentation of flutter_barcode_scanner 0.0.1 Download flutter_barcode_scanner 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Mar 23, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8