flutter_boost 0.0.25

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new40

flutter_boost #

A new Flutter plugin make flutter better to use!

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.1 #

  • TODO: Describe initial release.

example/README.md

flutter_boost_example #

Demonstrates how to use the flutter_boost plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_boost: ^0.0.25

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_boost/flutter_boost.dart';
  
Version Uploaded Documentation Archive
0.0.25 Feb 15, 2019 Go to the documentation of flutter_boost 0.0.25 Download flutter_boost 0.0.25 archive
0.0.24 Feb 13, 2019 Go to the documentation of flutter_boost 0.0.24 Download flutter_boost 0.0.24 archive
0.0.23 Feb 13, 2019 Go to the documentation of flutter_boost 0.0.23 Download flutter_boost 0.0.23 archive
0.0.22 Feb 13, 2019 Go to the documentation of flutter_boost 0.0.22 Download flutter_boost 0.0.22 archive
0.0.21 Feb 13, 2019 Go to the documentation of flutter_boost 0.0.21 Download flutter_boost 0.0.21 archive
0.0.2 Feb 13, 2019 Go to the documentation of flutter_boost 0.0.2 Download flutter_boost 0.0.2 archive
0.0.1 Feb 13, 2019 Go to the documentation of flutter_boost 0.0.1 Download flutter_boost 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
30
Health:
Code health derived from static analysis. [more]
45
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
58
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Feb 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0

Platforms

Detected platforms:

Error(s) prevent platform classification:

Error(s) in lib/container/boost_container.dart: 'ContainerNavigatorObserver.didStartUserGesture' ('() → void') isn't a valid override of 'NavigatorObserver.didStartUserGesture' ('(Route<dynamic>, Route<dynamic>) → void').

Health issues and suggestions

Fix lib/container/boost_container.dart. (-25 points)

Analysis of lib/container/boost_container.dart failed with 1 error:

line 268 col 3: 'ContainerNavigatorObserver.didStartUserGesture' ('() → void') isn't a valid override of 'NavigatorObserver.didStartUserGesture' ('(Route<dynamic>, Route<dynamic>) → void').

Fix lib/container/container_manager.dart. (-1.49 points)

Analysis of lib/container/container_manager.dart reported 3 hints:

line 181 col 33: The value of the local variable 'old' isn't used.

line 224 col 31: The value of the local variable 'old' isn't used.

line 241 col 31: The value of the local variable 'old' isn't used.

Fix lib/AIOService/NavigationService/service/NavigationService.dart. (-1 points)

Analysis of lib/AIOService/NavigationService/service/NavigationService.dart reported 2 hints:

line 17 col 22: 'listenEvent' is deprecated and shouldn't be used.

line 21 col 16: 'cancelEventForSubscription' is deprecated and shouldn't be used.

Fix additional 17 files with analysis or formatting issues. (-4 points)

Additional issues in the following files:

  • lib/AIOService/NavigationService/handlers/NavigationService_didDisappearPageContainer.dart (1 hint)
  • lib/AIOService/NavigationService/handlers/NavigationService_didInitPageContainer.dart (1 hint)
  • lib/AIOService/NavigationService/handlers/NavigationService_didShowPageContainer.dart (1 hint)
  • lib/AIOService/NavigationService/handlers/NavigationService_onNativePageResult.dart (1 hint)
  • lib/AIOService/NavigationService/handlers/NavigationService_willDeallocPageContainer.dart (1 hint)
  • lib/AIOService/NavigationService/handlers/NavigationService_willDisappearPageContainer.dart (1 hint)
  • lib/AIOService/NavigationService/handlers/NavigationService_willShowPageContainer.dart (1 hint)
  • lib/container/container_coordinator.dart (1 hint)
  • lib/AIOService/NavigationService/service/NavigationServiceRegister.dart (Run flutter format to format lib/AIOService/NavigationService/service/NavigationServiceRegister.dart.)
  • lib/AIOService/loader/ServiceLoader.dart (Run flutter format to format lib/AIOService/loader/ServiceLoader.dart.)
  • lib/flutter_boost.dart (Run flutter format to format lib/flutter_boost.dart.)
  • lib/messaging/message_proxy.dart (Run flutter format to format lib/messaging/message_proxy.dart.)
  • lib/messaging/native_page_container_event_handler.dart (Run flutter format to format lib/messaging/native_page_container_event_handler.dart.)
  • lib/messaging/page_result_mediator.dart (Run flutter format to format lib/messaging/page_result_mediator.dart.)
  • lib/router/boost_page_route.dart (Run flutter format to format lib/router/boost_page_route.dart.)
  • lib/router/router.dart (Run flutter format to format lib/router/router.dart.)
  • lib/support/logger.dart (Run flutter format to format lib/support/logger.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/container/boost_container.dart: 'ContainerNavigatorObserver.didStartUserGesture' ('() → void') isn't a valid override of 'NavigatorObserver.didStartUserGesture' ('(Route<dynamic>, Route<dynamic>) → void').

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
xservice_kit ^0.0.18 0.0.18
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8