flutter_bugfender 0.0.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new58

flutter_bugfender #

A Bugfender Wrapper plugin (implementing native code) for Flutter Projects.

Note : I didn't created this package. I only wrapped it, fixed SDK version and published. Original upload was to Git (you can find an example code there) : https://github.com/bugfender/BugfenderSDK-Flutter/tree/master/android

Note: THIS PLUGIN IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND AS IT'S A BETA VERSION:

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_bugfender: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_bugfender/flutter_bugfender.dart';
  
Version Uploaded Documentation Archive
0.0.4 Jan 30, 2019 Go to the documentation of flutter_bugfender 0.0.4 Download flutter_bugfender 0.0.4 archive
0.0.3 Jan 30, 2019 Go to the documentation of flutter_bugfender 0.0.3 Download flutter_bugfender 0.0.3 archive
0.0.2 Jan 30, 2019 Go to the documentation of flutter_bugfender 0.0.2 Download flutter_bugfender 0.0.2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
58
Learn more about scoring.

We analyzed this package on Feb 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13+1
  • Flutter: 1.2.1

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_bugfender.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8