flutter_calendar 0.0.1

  • README.md
  • Example
  • Installing
  • Versions
  • 46

flutter_calendar

A calendar widget for Flutter Apps.

Borrowed DateTime utility functions from the Tzolkin Calendar web element.

Usage

Add to your pubspec dependencies:

    flutter_calendar: ^0.0.1

Render the map with one of three options:

1. Default, Material Design

new Calendar()

standard view


2. An Expandable Map

new Calendar(
  isExpandable: true;
)

expanded view


3. Customize It (Standard or Expandable)

new Calendar(
  // A builder function that renders each calendar tile how you'd like.
  dayBuilder: new Text('!')
)

day builder


API

// Three optional params:
final VoidCallback onDateSelected;
final bool isExpandable;
final Widget dayBuilder;

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter_calendar/flutter_calendar.dart';

main() {
  runApp(new CalendarViewApp());
}

class CalendarViewApp extends StatelessWidget {
  void handleNewDate(date) {
    print(date);
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Flutter Demo',
      theme: new ThemeData(
        primarySwatch: Colors.purple,
      ),
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Flutter Calendar'),
        ),
        body: new Container(
          margin: new EdgeInsets.symmetric(
            horizontal: 5.0,
            vertical: 10.0,
          ),
          child: new ListView(
            shrinkWrap: true,
            children: <Widget>[
              new Text('The Default Calendar:'),
              new Calendar(
                onDateSelected: (date) => handleNewDate(date),
              ),
              new Divider(
                height: 50.0,
              ),
              new Text('The Expanded Calendar:'),
              new Calendar(
                isExpandable: true,
              ),
              new Divider(
                height: 50.0,
              ),
              new Text('A Custom Weekly Calendar:'),
              new Calendar(
                onSelectedRangeChange: (range) => print(range),
                isExpandable: true,
                dayBuilder: (BuildContext context, DateTime day) {
                  return new InkWell(
                    onTap: () => print(day),
                    child: new Container(
                      decoration: new BoxDecoration(
                          border: new Border.all(color: Colors.black38)),
                      child: new Text(
                        day.day.toString(),
                      ),
                    ),
                  );
                },
              ),
            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_calendar: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_calendar/flutter_calendar.dart';
  
Version Uploaded Documentation Archive
0.0.4 Jun 27, 2018 Go to the documentation of flutter_calendar 0.0.4 Download flutter_calendar 0.0.4 archive
0.0.3 Jun 26, 2018 Go to the documentation of flutter_calendar 0.0.3 Download flutter_calendar 0.0.3 archive
0.0.2 Apr 23, 2018 Go to the documentation of flutter_calendar 0.0.2 Download flutter_calendar 0.0.2 archive
0.0.1 Mar 20, 2018 Go to the documentation of flutter_calendar 0.0.1 Download flutter_calendar 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
93
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0