flutter_chameleon 0.1.4

  • README.md
  • Installing
  • Versions
  • 28




Flutter package to show platform dependent widgets.


Just use chameleon widgets instead of material or cupertino and they will show up depending on the hosting platform.

Widget included

  • activity indicator
  • alert dialog
  • bottom navigationbar
  • button
  • dialog
  • slider
  • switch
  • bottomSheet/picker

More to come..


Contributions of any kind are more than welcome! Feel free to fork and improve flutter_chameleon in any way you want, make a pull request, or open an issue.


First release


Critical fix


Minor clean up


Change flatbutton with materialbutton


Added chameleonPicker

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_chameleon: ^0.1.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_chameleon/flutter_chameleon.dart';
Version Uploaded Documentation Archive
0.1.4 May 7, 2018 Go to the documentation of flutter_chameleon 0.1.4 Download flutter_chameleon 0.1.4 archive
0.1.3 Apr 4, 2018 Go to the documentation of flutter_chameleon 0.1.3 Download flutter_chameleon 0.1.3 archive
0.1.2 Apr 3, 2018 Go to the documentation of flutter_chameleon 0.1.2 Download flutter_chameleon 0.1.2 archive
0.1.1 Apr 3, 2018 Go to the documentation of flutter_chameleon 0.1.1 Download flutter_chameleon 0.1.1 archive
0.1.0 Apr 3, 2018 Go to the documentation of flutter_chameleon 0.1.0 Download flutter_chameleon 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0


Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter packages pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0-dev.9.4.flutter-f9ebf21297.
 Because flutter_chameleon requires SDK version >=1.2.0 <=2.0.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Support latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use flutter_chameleon.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.2.0 <=2.0.0